cabal install fails

83 views
Skip to first unread message

Zouroboros Snake

unread,
Apr 11, 2016, 5:51:24 AM4/11/16
to leksah
Hi,

Im trying to install leksah via cabal install leksah Im getting the following error:

Resolving dependencies...
Configuring leksah-0.15.2.0...
Building leksah-0.15.2.0...
Preprocessing library leksah-0.15.2.0...

src/IDE/TextEditor/CodeMirror.hs:83:8-53:
    Could not find module ‘Graphics.UI.Gtk.WebKit.JavaScriptCore.WebFrame’
    It is a member of the hidden package ‘webkit-javascriptcore-0.13.1.2’.
    Perhaps you need to add ‘webkit-javascriptcore’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.
Failed to install leksah-0.15.2.0
cabal: Error: some packages failed to install:
leksah-0.15.2.0 failed during the building phase. The exception was:
ExitFailure 1

Any hints on how to resolve this? Or should a create an issue on github?

Thanks in advance

buha

unread,
Apr 17, 2016, 10:35:10 AM4/17/16
to leksah
Same for me on Manjaro Linux
I tried to install manually the leksah .tar.gz by removing at the same time the offending line where webkit-javascriptcore is included as dependency, but it doesn't work (other errors thrown).

The Glorious Glasgow Haskell Compilation System, version 7.10.3
cabal-install version 1.22.9.0
using version 1.22.5.0 of the Cabal library

buha

unread,
Apr 17, 2016, 10:53:57 AM4/17/16
to leksah
After posting here I found this thread which is seemingly related because it fixed the problem for me.
https://github.com/leksah/leksah/issues/251
Reply all
Reply to author
Forward
0 new messages