Having trouble getting started with the Mac OS version

73 views
Skip to first unread message

j...@adazza.com

unread,
Feb 27, 2018, 12:37:32 PM2/27/18
to leksah
I recently downloaded the 0.16.2 version for Mac OS and got it reasonably successfully installed, but am having trouble getting started.

First issue:

The "hello world" sample project comes up when I start Leksah, and the first time I tried building, it invoked the compile and generated object files. However, when I try to run the project, I just get:

echo 'TODO run cabal new-install'
TODO run cabal new-install
-----------------------------------------


and no output appears in the log. Likewise, the "clean" command doesn't seem to do anything either. It simply prints "cleaning..." but never removes any of the build artifacts.

Second issue:

Trying to view/change the preferences by clicking on the preferences menu item causes an instant crash. The only log messages I could find were in syslog:

Feb 27 09:29:39 ip-10-44-7-245 com.apple.xpc.launchd[1] (org.leksah.10368[46708]): Service exited with abnormal code: 1

and in the Console:

default    09:29:39.903978 -0800    kernel    AGC:: [leksah pid 46708 mux-aware] exiting, non-mux-aware app count 1, runtime: 0:08:53.112

If you can point me toward where Leksah write its logs I can capture what happens there if it would help.

I'm using GHC 8.2.2 and Cabal 2.0.0.1 both installed via homebrew. Running on Mac OS 10.13.3.

I've tried building from the latest trunk bits, but have hit the wall trying to get a working Webkit-GTK. Homebrew stopped providing it (because it was too hard to build reliably...) and I cannot get it to build from sources.

-Jon


Reply all
Reply to author
Forward
0 new messages