Offline installation

6 views
Skip to first unread message

ign...@gmail.com

unread,
Nov 21, 2013, 9:03:36 AM11/21/13
to kwa...@googlegroups.com
How to execute clean up and pre setup task.

I have this offline descriptor
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<bundle version="1.0" name="installer">
<environments>
<environment name="ng_tp">
<deployments>
<deployment name="20131121_ng_tp">
<server_packages>
<server name="tp_talin01">
<kwatee_deployment_dir>/var/tmp/kwatee/ng_tp/20131121_ng_tp</kwatee_deployment_dir>
<pre_setup_action><![CDATA[/etc/init.d/tomcat stop]]></pre_setup_action>
<post_setup_action><![CDATA[/etc/init.d/tomcat start]]></post_setup_action>
<pre_cleanup_action><![CDATA[/etc/init.d/tomcat stop]]></pre_cleanup_action>
<post_cleanup_action><![CDATA[/etc/init.d/tomcat start]]></post_cleanup_action>
<package name="ng" active_version="1.0.1.0.1-SNAPSHOT">
<kwatee_package_dir>/usr/apache-tomcat/webapps/ROOT</kwatee_package_dir>
</package>
</server>
</server_packages>
</deployment>
</deployments>
</environment>
</environments>
</bundle>


but in console i get
[root@talin01 apache-tomcat]# ./linux_64_kwdeploy tp_talin01 ng
Installation of deployment ng_tp-20131121_ng_tp
===============================================
No pre-setup script script

Deploy ng
----------
/usr/apache-tomcat/webapps/ROOT:
No pre-deploy script script


No post-deploy script script

No post-setup script script

COMPLETED


Its bug or designed feature

Mac

unread,
Nov 25, 2013, 1:06:45 AM11/25/13
to
The bug is confirmed. This is fixed in update 2.1.14 which was released on Nov 24, 2013

Thanks for your feedback
Reply all
Reply to author
Forward
0 new messages