Groups
Groups
Sign in
Groups
Groups
KUnit Development
Conversations
About
Send feedback
Help
Group path
KUnit Development
Contact owners and managers
1–30 of 1442
Mark all as read
Report group
0 selected
Karl Mehltretter
, …
netdev-bo...@kernel.org
9
4:55 PM
[PATCH net-next] net: mctp: Stop selecting flow support for KUnit tests
Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider. Critical:
unread,
[PATCH net-next] net: mctp: Stop selecting flow support for KUnit tests
Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider. Critical:
4:55 PM
jahanzaibmir
4:37 PM
[PATCH] kunit: tool: remove unused JUnit imports
The JUnit output implementation uses ElementTree directly, so the xml.sax.saxutils imports are unused
unread,
[PATCH] kunit: tool: remove unused JUnit imports
The JUnit output implementation uses ElementTree directly, so the xml.sax.saxutils imports are unused
4:37 PM
Gary Guo
,
Miguel Ojeda
3
1:41 PM
[PATCH RESEND] rust: doctest: trim function name for reproducbility
On Thu, Sep 24, 2026 at 2:51 AM Gary Guo <ga...@kernel.org> wrote: > > From: Gary Guo <
unread,
[PATCH RESEND] rust: doctest: trim function name for reproducbility
On Thu, Sep 24, 2026 at 2:51 AM Gary Guo <ga...@kernel.org> wrote: > > From: Gary Guo <
1:41 PM
Ziran Zhang
9:04 AM
Re: [PATCH v3 2/2] list: add KUnit test for list_cut_before() empty list case
Hi David, Patch 2 touches lib/tests/list-test.c, which you maintain. It adds a KUnit test case for
unread,
Re: [PATCH v3 2/2] list: add KUnit test for list_cut_before() empty list case
Hi David, Patch 2 touches lib/tests/list-test.c, which you maintain. It adds a KUnit test case for
9:04 AM
Demian Shulhan
, …
Jakub Kicinski
5
Sep 29
[PATCH 0/2] arm64: csum: Add fused copy and Internet checksum
On Sun, 27 Sep 2026 15:17:56 +0200 Demian Shulhan wrote: > arm64 currently uses the generic
unread,
[PATCH 0/2] arm64: csum: Add fused copy and Internet checksum
On Sun, 27 Sep 2026 15:17:56 +0200 Demian Shulhan wrote: > arm64 currently uses the generic
Sep 29
Simon Sudarushkin via B4 Relay
Sep 29
[PATCH] kunit: tool: report executor errors when listing tests
From: Simon Sudarushkin <simonsud...@gmail.com> --list_tests, --list_suites, --
unread,
[PATCH] kunit: tool: report executor errors when listing tests
From: Simon Sudarushkin <simonsud...@gmail.com> --list_tests, --list_suites, --
Sep 29
SJ Park
11
Sep 29
[RFC PATCH 0/7] mm/damon: introduce damos quota goal target metric complement flag
On Tue, 29 Sep 2026 01:01:03 -0700 SJ Park <s...@kernel.org> wrote: [...] > Add a new flag,
unread,
[RFC PATCH 0/7] mm/damon: introduce damos quota goal target metric complement flag
On Tue, 29 Sep 2026 01:01:03 -0700 SJ Park <s...@kernel.org> wrote: [...] > Add a new flag,
Sep 29
SJ Park
2
Sep 28
[PATCH v3 0/2] mm/damon/core: preserve quota state when constructing schemes
From: Karl Mehltretter <kmehlt...@gmail.com> Check that damon_new_scheme() initializes the
unread,
[PATCH v3 0/2] mm/damon/core: preserve quota state when constructing schemes
From: Karl Mehltretter <kmehlt...@gmail.com> Check that damon_new_scheme() initializes the
Sep 28
SJ Park
2
Sep 28
[PATCH v5 0/2] mm/damon: fix the temporal goal tuner's size quota conversion
From: Donggeun Yoo <donggeuny...@gmail.com> damos_goal_tune_esz_bp_temporal() encodes the
unread,
[PATCH v5 0/2] mm/damon: fix the temporal goal tuner's size quota conversion
From: Donggeun Yoo <donggeuny...@gmail.com> damos_goal_tune_esz_bp_temporal() encodes the
Sep 28
SJ Park
2
Sep 28
[PATCH 0/3] mm/damon/core: cleanup code, reduce stack usage, and add kunit
From: Karl Mehltretter <kmehlt...@gmail.com> Test the PSI current-value helper with explicit
unread,
[PATCH 0/3] mm/damon/core: cleanup code, reduce stack usage, and add kunit
From: Karl Mehltretter <kmehlt...@gmail.com> Test the PSI current-value helper with explicit
Sep 28
Bill Wendling
, …
Thomas Weißschuh
7
Sep 28
[PATCH 2/2] lib/tests: Add KUnit test for struct stack_trace __counted_by_ptr attribute
Hi Bill, sorry for the long delay. On Thu, Sep 10, 2026 at 12:48:51PM -0700, Bill Wendling wrote:
unread,
[PATCH 2/2] lib/tests: Add KUnit test for struct stack_trace __counted_by_ptr attribute
Hi Bill, sorry for the long delay. On Thu, Sep 10, 2026 at 12:48:51PM -0700, Bill Wendling wrote:
Sep 28
Hajime Tazaki
Sep 27
[PATCH] um: require MMU for UML PCI support
Because UML_PCI (arch/um/drivers/Kconfig) selects FORCE_PCI, this contradicts the current dependency
unread,
[PATCH] um: require MMU for UML PCI support
Because UML_PCI (arch/um/drivers/Kconfig) selects FORCE_PCI, this contradicts the current dependency
Sep 27
donia ahadhr
Sep 27
الدبلوم المهني لمدير الموارد البشرية المعتمدCHRMCertified Human Resources Managerيبدأ من 4 أكتوبر 2026 40 ساعة تدريبية معتمدة دبلوم مهني معتمد نبذة عن الدبلوميقدم دبلوم CHRM – Certified Human Resources Manager برنامجًا مهنيًا متكاملًا لتطوير قدرات مديري ومسؤولي الموارد البشرية، وتمكينهم من إدارة رأس المال البشري وفق أفضل الممارسات الإدارية الحديثة.يركز الدبلوم على الانتقال بإدارة الموارد البشرية من الدور التشغيلي التقليدي إلى الدور الاستراتيجي، من خلال تطوير سياسات وممارسات الموارد البشرية، وإدارة المواهب، وتخطيط القوى العاملة، وإدارة الأداء، والتعويضات والمزايا، والت
🏴الدبلوم المهني لمدير الموارد البشرية المعتمد CHRM Certified Human Resources Manager يبدأ من 4 أكتوبر
unread,
الدبلوم المهني لمدير الموارد البشرية المعتمدCHRMCertified Human Resources Managerيبدأ من 4 أكتوبر 2026 40 ساعة تدريبية معتمدة دبلوم مهني معتمد نبذة عن الدبلوميقدم دبلوم CHRM – Certified Human Resources Manager برنامجًا مهنيًا متكاملًا لتطوير قدرات مديري ومسؤولي الموارد البشرية، وتمكينهم من إدارة رأس المال البشري وفق أفضل الممارسات الإدارية الحديثة.يركز الدبلوم على الانتقال بإدارة الموارد البشرية من الدور التشغيلي التقليدي إلى الدور الاستراتيجي، من خلال تطوير سياسات وممارسات الموارد البشرية، وإدارة المواهب، وتخطيط القوى العاملة، وإدارة الأداء، والتعويضات والمزايا، والت
🏴الدبلوم المهني لمدير الموارد البشرية المعتمد CHRM Certified Human Resources Manager يبدأ من 4 أكتوبر
Sep 27
SJ Park
3
Sep 27
[RFC PATCH v4 0/7] snapshot_set_swap_area() unpins the previously selected swap device and
On Sun, 27 Sep 2026 05:05:24 -0700 SJ Park <s...@kernel.org> wrote: > Add
unread,
[RFC PATCH v4 0/7] snapshot_set_swap_area() unpins the previously selected swap device and
On Sun, 27 Sep 2026 05:05:24 -0700 SJ Park <s...@kernel.org> wrote: > Add
Sep 27
Karl Mehltretter
,
Bradley Morgan
2
Sep 26
[PATCH] resource, kunit: stop selecting GET_FREE_REGION
On 26 September 2026 01:26:51 BST, Karl Mehltretter <kmehlt...@gmail.com> wrote: >
unread,
[PATCH] resource, kunit: stop selecting GET_FREE_REGION
On 26 September 2026 01:26:51 BST, Karl Mehltretter <kmehlt...@gmail.com> wrote: >
Sep 26
Thomas Weißschuh
, …
Karl Mehltretter
4
Sep 25
[PATCH] kunit: Return void from kunit_run_all_tests()
On Mon, Sep 14, 2026 at 04:59:33AM +0200, Karl Mehltretter wrote: > kunit_run_all_tests() jumps to
unread,
[PATCH] kunit: Return void from kunit_run_all_tests()
On Mon, Sep 14, 2026 at 04:59:33AM +0200, Karl Mehltretter wrote: > kunit_run_all_tests() jumps to
Sep 25
Karl Mehltretter
, …
Herbert Xu
3
Sep 23
[PATCH] lib/842: depend on the decompressor for KUnit tests
On Thu, Sep 17, 2026 at 07:56:45AM +0200, Karl Mehltretter wrote: > 842_DECOMPRESS_KUNIT_TEST
unread,
[PATCH] lib/842: depend on the decompressor for KUnit tests
On Thu, Sep 17, 2026 at 07:56:45AM +0200, Karl Mehltretter wrote: > 842_DECOMPRESS_KUNIT_TEST
Sep 23
Karl Mehltretter
, …
patchwork-b...@kernel.org
4
Sep 21
[PATCH net] net: microchip: vcap: Stop selecting DEBUG_FS for KUnit tests
Hello: This patch was applied to netdev/net-next.git (main) by Jakub Kicinski <ku...@kernel.org>
unread,
[PATCH net] net: microchip: vcap: Stop selecting DEBUG_FS for KUnit tests
Hello: This patch was applied to netdev/net-next.git (main) by Jakub Kicinski <ku...@kernel.org>
Sep 21
SJ Park
2
Sep 21
[PATCH v2 0/2] mm/damon/core: fix the size charged for a filter-trimmed region
From: Donggeun Yoo <donggeuny...@gmail.com> damos_test_filter_out() checks that an
unread,
[PATCH v2 0/2] mm/damon/core: fix the size charged for a filter-trimmed region
From: Donggeun Yoo <donggeuny...@gmail.com> damos_test_filter_out() checks that an
Sep 21
Wadim Mueller
,
Jonathan Cameron
6
Sep 20
[PATCH 0/2] iio: flow: slf3s: fix and test the vdd supply balance
On Fri, 04 Sep 2026 21:24:24 +0200 Wadim Mueller <waf...@gmail.com> wrote: > Li Youhong
unread,
[PATCH 0/2] iio: flow: slf3s: fix and test the vdd supply balance
On Fri, 04 Sep 2026 21:24:24 +0200 Wadim Mueller <waf...@gmail.com> wrote: > Li Youhong
Sep 20
Kees Cook
Sep 20
[PATCH] Documentation: kunit: Fix KUNIT_DEFINE_ACTION_WRAPPER() argument order
The macro is #define KUNIT_DEFINE_ACTION_WRAPPER(wrapper, orig, arg_type) ... so it defines "
unread,
[PATCH] Documentation: kunit: Fix KUNIT_DEFINE_ACTION_WRAPPER() argument order
The macro is #define KUNIT_DEFINE_ACTION_WRAPPER(wrapper, orig, arg_type) ... so it defines "
Sep 20
SJ Park
,
Andrew Morton
8
Sep 17
[RFC PATCH v2 00/10] mm/damon: improve readability, clarity and test coverage
On Thu, 17 Sep 2026 07:21:58 -0700 SJ Park <s...@kernel.org> wrote: > Yet another batch of
unread,
[RFC PATCH v2 00/10] mm/damon: improve readability, clarity and test coverage
On Thu, 17 Sep 2026 07:21:58 -0700 SJ Park <s...@kernel.org> wrote: > Yet another batch of
Sep 17
Karl Mehltretter
, …
Geert Uytterhoeven
5
Sep 15
[PATCH v1 0/3] lib/842: reject malformed streams before invalid memory accesses
On Tue, Sep 15, 2026 at 02:57:55PM +0100, Geert Uytterhoeven wrote: > > +config
unread,
[PATCH v1 0/3] lib/842: reject malformed streams before invalid memory accesses
On Tue, Sep 15, 2026 at 02:57:55PM +0100, Geert Uytterhoeven wrote: > > +config
Sep 15
SJ Park
,
KunWu Chan
13
Sep 14
[RFC PATCH 0/8] mm/damon: move damos filter range arguments validation to core
On Tue, Sep 15, 2026 at 7:49 AM SJ Park <s...@kernel.org> wrote: > > Hi Kunwu, > > On
unread,
[RFC PATCH 0/8] mm/damon: move damos filter range arguments validation to core
On Tue, Sep 15, 2026 at 7:49 AM SJ Park <s...@kernel.org> wrote: > > Hi Kunwu, > > On
Sep 14
SJ Park
,
Andrew Morton
4
Sep 14
[PATCH 0/6] mm/damon: misc improvements in tests and documents
On Mon, 14 Sep 2026 07:19:45 -0700 SJ Park <s...@kernel.org> wrote: > Add various improvements
unread,
[PATCH 0/6] mm/damon: misc improvements in tests and documents
On Mon, 14 Sep 2026 07:19:45 -0700 SJ Park <s...@kernel.org> wrote: > Add various improvements
Sep 14
David Gow
, …
Tvrtko Ursulin
9
Sep 14
[PATCH] drm/sched: Increase drm_mock_sched_job_wait_finished timeout when CONFIG_HZ=100
Le 14/09/2026 à 8:12 PM, Tvrtko Ursulin a écrit : > > On 14/09/2026 12:48, Philipp Stanner
unread,
[PATCH] drm/sched: Increase drm_mock_sched_job_wait_finished timeout when CONFIG_HZ=100
Le 14/09/2026 à 8:12 PM, Tvrtko Ursulin a écrit : > > On 14/09/2026 12:48, Philipp Stanner
Sep 14
Thomas Weißschuh
,
Michal Simek
3
Sep 14
[PATCH v2 0/5] microblaze: KUnit support
On 9/14/26 01:50, Thomas Weißschuh wrote: > Add the necessary prerequisites and configuration to
unread,
[PATCH v2 0/5] microblaze: KUnit support
On 9/14/26 01:50, Thomas Weißschuh wrote: > Add the necessary prerequisites and configuration to
Sep 14
Thomas Weißschuh
Sep 13
[PATCH v2 1/5] microblaze: uaccess: Zero out destination on failed get_user()
On failure get_user() is supposed to zero out the destination variable. This is documented in the
unread,
[PATCH v2 1/5] microblaze: uaccess: Zero out destination on failed get_user()
On failure get_user() is supposed to zero out the destination variable. This is documented in the
Sep 13
Thomas Weißschuh
Sep 13
[PATCH v2 4/5] microblaze: reset: Provide a power off handler through an unaligned PC
microblaze is missing a generic architecture-wide power off mechanism. To enable KUnit for microblaze
unread,
[PATCH v2 4/5] microblaze: reset: Provide a power off handler through an unaligned PC
microblaze is missing a generic architecture-wide power off mechanism. To enable KUnit for microblaze
Sep 13
Thomas Weißschuh
Sep 13
[PATCH v2 3/5] microblaze: reset: Call POWER_OFF handlers
System power off might be implemented through sys_off handlers. Currently these are not respected on
unread,
[PATCH v2 3/5] microblaze: reset: Call POWER_OFF handlers
System power off might be implemented through sys_off handlers. Currently these are not respected on
Sep 13