[Security Advisory] CVE-2023-1174, CVE-2023-1944: Network port exposure and ssh access using default password

850 views
Skip to first unread message

Vellore Rajakumar, Sri Saran Balaji

unread,
Apr 12, 2023, 2:38:30 PM4/12/23
to kubernete...@googlegroups.com, d...@kubernetes.io, kubernetes-sec...@googlegroups.com, kubernetes-se...@googlegroups.com, distributo...@kubernetes.io, kubernetes+a...@discoursemail.com

Hello Kubernetes Community,

 

We have released minikube v1.30.0 to address two security issues in minikube. We recommend all to upgrade minikube to the latest version and delete any Kubernetes clusters created with an affected version. Minikube is a utility tool that sets up a Kubernetes environment on a local machine for developing and testing Kubernetes applications. Minikube is not intended for production use.

 

CVE-2023-1174: Network port exposure

 

This vulnerability exposes a network port in minikube running on macOS with Docker driver that could enable unexpected remote access to the minikube container. This issue has been rated CRITICAL (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H) (score: 9.8).

 

Am I vulnerable?

This CVE only affects clusters running on macOS with Docker drivers. If you have created the Kubernetes cluster using one of the below mentioned minikube versions, then you are affected by this vulnerability. 

 

Affected Versions

• v1.28.0

• v1.27.1

• v1.27.0

• v1.26.1

• v1.26.0

 

You can also run the following command to know if you are affected. If the command returns 0.0.0.0 then you are affected by this vulnerability.

`docker inspect --format='{{(index (index .NetworkSettings.Ports "8443/tcp") 0).HostIp}}' minikube`

 

CVE-2023-1944: SSH access using default password

 

This vulnerability enables ssh access to minikube container using a default password. This issue has been rated HIGH (CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H) (score: 8.4).

 

Am I vulnerable?

 

All versions prior to v.1.30.0 are affected.

 

To find the version deployed in your environment, run the following command - 

`minikube version`

 

How do I remediate these vulnerabilities?

 

To mitigate these vulnerabilities, you must upgrade minikube to the latest version and delete any clusters created using an affected version.

 

Fixed Version

• v1.30.0

 

Note: To delete clusters created using prior versions, run `minikube delete --all`

 

Thank You,

Balaji on behalf of the Kubernetes Security Response Committee

 

Reply all
Reply to author
Forward
0 new messages