Trouble with KoboSync/Post Processor

Skip to first unread message

Greg Papciak

Apr 9, 2014, 4:20:21 AM4/9/14

I am a new user to KoboToolBox. I am having some problems with KoboSync and getting data off the tablet onto my laptop. When I attach my ASUS ME173X (running Android 4.2.2) to my Windows 8 laptop and then open KoboSync (Post Processor) and try to input the proper "survey instances" folder from the mobile device, the mobile device does not even show up as an option (but it does show up in windows explorer). So I thought I should try to manually take the files off of the mobile device and place on my laptop. However, when I attach the device to my laptop and try to navigate to the "instances" folder with windows explorer, the "instances" folder is missing (and all attempts to unhide or otherwise reveal the file didn't work). But when I open the "file manager" directly on the mobile device, I can see the "instances" folder as a sub-folder in the ODK folder, with the completed surveys included in it.  

I am hoping someone can provide some advice on how to move forward and retrieve the completed forms.

Thank you,
Arusha, Tanzania

Patrick Vinck

Apr 9, 2014, 12:00:37 PM4/9/14
Hi Greg,

I assume the ASUS ME173X  uses internal memory, like the nexus 7.  

Since you see the folders on your devices, the issue is about connecting it to your PC. This is outside of KoBoSync, but a known issue.
The problem is that the MTP software on Windows does not update the directories when connecting the device. A few things that may work:

(1) reboot the device itself
(2) if i does not work, you can try to enable debugging mode on your android tablet - it is not needed normally, but sometimes prompt Windows to update the directories.

Hopefully these simple steps will resolve your problem. 

It has worked for me in the past (we have deployed hundreds of devices, including Nexus 7 tablets which were the only ones causing this problem)
However,t here is one tablet for which I was never able to see the ODK folders - never understood why - may be someone on the list can help? 
The only workaround I found was to install dropsync and use the wifi connection to sync the data. This defeats the purpose of being able to do this completely offline. you may want to try the Bluetooth connection. 



You received this message because you are subscribed to the Google Groups "Kobo Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To post to this group, send email to
Visit this group at
For more options, visit

Greg Papciak

Apr 10, 2014, 2:51:57 AM4/10/14
Hi Patrick,

Thanks very much this advice! A simple restart did work to enable the "instances" folder to show up in Windows Explorer. The ASUS device is still not showing up in KoboSync, but at least I have a way to get the data off the tablet now.

All the best,

You received this message because you are subscribed to a topic in the Google Groups "Kobo Users" group.
To unsubscribe from this topic, visit
To unsubscribe from this group and all its topics, send an email to

Tino Kreutzer

Apr 10, 2014, 12:04:45 PM4/10/14
Hi Greg,
Unfortunately recent changes to the Android platform mean that you can no longer see a path to your files directly in KoBoSync (or any other software of the kind for that matter). However, to copy files from your tablet to your hard drive you are doing the right approach: Just copy-paste the 'instances' folder inside of /sdcard/odk to your computer, then point KoBoSync to the location where you copied the instances folder to. 

Let us know if you have any other questions!

Tino Kreutzer
Program Manager
KoBoToolbox | Harvard Humanitarian Initiative

Reply all
Reply to author
0 new messages