Knative Upgrading Steps

32 views
Skip to first unread message

Andrey Stelmashenko

unread,
May 27, 2022, 5:02:04 AMMay 27
to Knative Users
Hi Community,
We are on knative 0.24.0 version and trying to understand how safe is it to upgrade to latest stable release.
What I've found on the official website is that we need to upgrade version by version
0.24 to 0.25 and so on until latest version.
I do not see what to expect, e.g. breaking changes between 0.x and 1.x versions, anything deprecated/removed from knative api (yaml files spec)?

Could you please confirm that docs are relevant and we just need to follow 
https://knative.dev/docs/install/upgrade/upgrade-installation-with-operator/  several times to update to 1.4.x and that's it?

Thanks!

Evan Anderson

unread,
May 27, 2022, 12:54:21 PMMay 27
to Andrey Stelmashenko, Knative Users
Hi Andrey,

Except for an error in the 1.3 release fixed in 1.3.1 where the semantics of `timeoutSeconds` changed, I'm not aware of breaking API changes between those versions. We recommend upgrading one patch release at a time because we test that upgrade and downgrade path, but don't test skipping multiple patches.

I suspect some vendors do multi-patch upgrades. In theory that _could_ be safe if there aren't any API changes which are fixed by storage version migrations, but we haven't tracked that explicitly. One example of this is that eventing 0.24 from 0.23 needs a job to be run after the install to upgrade the storage version to v1. Not doing this and skipping to a release which dropped the v1beta2 APIs would cause all your existing eventing resources to fail.


From: knativ...@googlegroups.com <knativ...@googlegroups.com> on behalf of Andrey Stelmashenko <astelm...@viax.io>
Sent: Friday, May 27, 2022 2:02:04 AM
To: Knative Users <knativ...@googlegroups.com>
Subject: [Suspected Spam] Knative Upgrading Steps
 

⚠ External Email

--
You received this message because you are subscribed to the Google Groups "Knative Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to knative-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/knative-users/95fd126b-83ec-4720-8621-6a6b4bfc39f5n%40googlegroups.com.


⚠ External Email: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender.

David Protasowski

unread,
May 27, 2022, 1:02:25 PMMay 27
to Andrey Stelmashenko, Knative Users, Evan Anderson
We recommend upgrading one patch release at a time because we test that upgrade and downgrade path, but don't test skipping multiple patches.

We actually support minor version upgrades and preferable to the latest minor.  Thus 0.24=>0.25 etc. and like Evan suggested run the necessary post-install jobs (i.e. storage-version-migrator)

For serving there are some reports of users encountering issues when doing larger jumps




From: 'Evan Anderson' via Knative Users <knativ...@googlegroups.com>
Sent: Friday, May 27, 2022 12:54 PM
To: Andrey Stelmashenko <astelm...@viax.io>; Knative Users <knativ...@googlegroups.com>
Subject: Re: [Suspected Spam] Knative Upgrading Steps
 

⚠ External Email

Andrey Stelmashenko

unread,
May 31, 2022, 5:21:14 AMMay 31
to Knative Users
Thank you, guys, we will follow your advices
Reply all
Reply to author
Forward
0 new messages