kiwi-ng error KiwiInstallPhaseFailed

255 views
Skip to first unread message

Jay Patel

unread,
Feb 5, 2019, 9:10:40 PM2/5/19
to kiwi
Hello all suseHackers,

I am having error while making iso using kiwi-ng :


[ ERROR ]: 21:03:19 | KiwiInstallPhaseFailed: System package installation failed:
[ INFO ]: 21:03:19 | Cleaning up SystemPrepare instance
[ WARNING ]: 21:03:19 | remove_hierarchy: path /tmp is protected

any idea what it could be ? Need any log file from to check ?

Regards,
Jay

David Cassany

unread,
Feb 6, 2019, 2:31:00 AM2/6/19
to kiwi-...@googlegroups.com
Hi Jay,
You are looking to the wrong part of the logs. This is a common issue,
sometimes is hard to see what failed during the installation of a package.
Zypper when installs a package that reports an error during the installation
continues installing all other packages that were required and at the end of
everything returns the error code.

> KiwiInstallPhaseFailed: System package installation

It mostly indicates that during a 'zypper install ...' call something when
wrong. Usually, and this is just a guess, when this is not obvious at first
sight it means that some scriptlet of a package failed. I'd look for the
'scriptlet' key word in your build log file, usually this will point you to
the offending package.

If the above does not help you to figure out what is going on please consider
sharing the build logs or at least the portion from the zypper install call up
to the failure.

Best regards,
David
signature.asc

Jay Patel

unread,
Feb 6, 2019, 4:57:07 AM2/6/19
to kiwi-...@googlegroups.com
Hello David,

Please find my log from kiwi : https://pastebin.com/DL8inqnj

seems like vlc is breaking it. but it automatically cancelled build.

Regards,
Jay

--
You received this message because you are subscribed to the Google Groups "kiwi" group.
To unsubscribe from this group and stop receiving emails from it, send an email to kiwi-images...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

Till Dörges

unread,
Feb 6, 2019, 5:25:33 AM2/6/19
to kiwi-...@googlegroups.com, Jay Patel
Am 06.02.19 um 10:56 schrieb Jay Patel:

> seems like vlc is breaking it. but it automatically cancelled build.

Yes, more precisely zypper complains about these 4 problems:

--- snip ---
DEBUG: 15:15:09 | system: 4 Problems:
DEBUG: 15:15:09 | system: Problem: nothing provides libx264.so.152()(64bit) needed by
libavcodec57-3.4.5-3.3.x86_64
DEBUG: 15:15:09 | system: Problem: nothing provides libx264.so.152()(64bit) needed by
libquicktime-orig-addon-1.2.4+git20180207.666c35c-3.12.x86_64
DEBUG: 15:15:09 | system: Problem: nothing provides libx264.so.152()(64bit) needed by
vlc-codecs-3.0.6-5.3.x86_64
DEBUG: 15:15:09 | system: Problem: nothing provides libx264.so.152()(64bit) needed by
libavcodec57-3.4.5-3.3.x86_64
DEBUG: 15:15:09 | system: Problem: nothing provides libx264.so.152()(64bit) needed by
libavcodec57-3.4.5-3.3.x86_64
--- snap ---

Kiwi doesn't know what to do, so it aborts:

--- snip ---
DEBUG: 15:15:09 | system: Solution 1: do not install libavcodec57-3.4.5-3.3.x86_64
DEBUG: 15:15:09 | system: Solution 2: break libavcodec57-3.4.5-3.3.x86_64 by
ignoring some of its dependencies
DEBUG: 15:15:09 | system: Choose from above solutions by number or skip, retry or
cancel [1/2/s/r/c] (c): c
ERROR: 15:15:09 | KiwiInstallPhaseFailed: System package installation failed:
--- snap ---


Your best bet is to make sure that all the packages that are required are available
in the repositories.


HTH -- Till
--
Dipl.-Inform. Till Dörges doe...@pre-sense.de
Tel. +49 - 40 - 244 2407 - 0
Fax +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander USt-IdNr.: DE263765024

Jay Patel

unread,
Feb 6, 2019, 8:11:56 AM2/6/19
to Till Dörges, kiwi-...@googlegroups.com
Hello Till,

Thanks,  i can see packages in repo packman that i have added in config somehow its clashing i will see and play around a bit if i can get it working.

Thanks,
Jay

Jay Patel

unread,
Feb 7, 2019, 1:57:28 AM2/7/19
to kiwi-...@googlegroups.com
Hello All,

how one can add to retry for packages in script? sometimes one package cannot be retrieved but when run script again it fetches from repo. but then some other cannot be retrieved.

Thanks,
Jay
Reply all
Reply to author
Forward
0 new messages