Unable to see my plugin installed in KPM of Kaui

34 views
Skip to first unread message

maxime kalla

unread,
Sep 24, 2021, 7:26:29 AMSep 24
to Kill Bill users mailing-list
Hi everyone, 

I have installed my killbill with docker and my config is : 

killbill/killbill : 0.22.26
killbill/kaui : 2.0.9
killbill/mariadb : 0.22

kpm-inspect.png

Hi have build a payment plugin for killbill and when I installed it everything went well :

killbill-plugin-install.png

but I can see my plugin in the Kaui : 

kaui-screen.png

This is the link of my code  : killbill-momofflw-plugin

And attach the logs file.

Can I receive an assist to solve this issue ?

killbill.out

Pierre-Alexandre Meyer

unread,
Sep 28, 2021, 2:11:07 PMSep 28
to maxime kalla, Kill Bill users mailing-list
Hello,

According to the logs, the plugin directory in the container (/var/lib/killbill/bundles) is empty:

2021-09-24T08:46:57,488+0000 lvl='WARN', log='PluginFinder', th='localhost-startStop-1', xff='', rId='', tok='', aRId='', tRId='', Configuration root dir /var/lib/killbill/bundles/plugins/java is not a valid directory

Maybe the plugin was installed in the wrong container and/or there is a mounted volume?



--
You received this message because you are subscribed to the Google Groups "Kill Bill users mailing-list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to killbilling-us...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/killbilling-users/ca3c34af-fad1-425d-b790-eefe7421ee14n%40googlegroups.com.


--
Pierre

maxime kalla

unread,
Sep 29, 2021, 8:46:11 AMSep 29
to Kill Bill users mailing-list
Thank's for your reply, the plugin is installed well and I can see it in the KPM.

Now when I try to add a Payment Method I got the error : Error while creating payment method: Payment plugin killbill-MomoFrancophoneFlutterWave is not registered 

Reshma Bidikar

unread,
Oct 1, 2021, 4:11:52 AMOct 1
to Kill Bill users mailing-list

Hello,

I am a part of the Kill Bill team. I am following up on this question on behalf of Pierre. So, we think the plugin may have failed to start. Do you see anything in the logs related to this?

Regards,
Reshma
Reply all
Reply to author
Forward
0 new messages