openid authentication is failing with no rbac and using AzureAD

8 views
Skip to first unread message

Lucky Verma

unread,
Sep 20, 2022, 3:01:06 PMSep 20
to kiali-dev
Below are the logs I am getting while configuring the openid with no rbac and with azureAD:
2022-09-19T12:19:32Z ERR Not handling OpenId code flow authentication: no authorization code is present
2022-09-19T12:21:05Z WRN Configured OpenID provider informs some of the configured scopes are unsupported. Users may not be able to login

Also I had observed that while going with openid kiali url is redirecting to url having port 20001 e.g. from https://kiali.xxx.xx/kiali to kiali.xxx.xx:20001/kiali

its weird because while I am using token based authentication url is not redirecting..

Please someone can suggest best approach.

jmaz...@redhat.com

unread,
Sep 20, 2022, 3:11:34 PMSep 20
to kiali-dev
Here are the docs for Kiali OpenID config - it has a section regarding Azure-specific set up. So review this page and see if anything helps:

https://kiali.io/docs/configuration/authentication/openid/

Jay Shaughnessy

unread,
Sep 20, 2022, 10:18:10 PMSep 20
to kial...@googlegroups.com

By the way, this mailing list is no longer regularly monitored.  We encourage you to use any of the contact points found here: https://kiali.io/community/, especially Slack and Github.  Don't use IRC, that also is no longer monitored and will be removed from the website.
--
You received this message because you are subscribed to the Google Groups "kiali-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to kiali-dev+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/kiali-dev/c025adfd-e5ee-4149-984d-26dbddd4fbf2n%40googlegroups.com.

Lucky Verma

unread,
Sep 21, 2022, 5:23:44 AMSep 21
to kiali-dev
Hi, I had followed the same document, still facing issue.
Reply all
Reply to author
Forward
0 new messages