Data de vencimento máxima

16 views
Skip to first unread message

Carlos Backup

unread,
Jun 5, 2020, 8:56:18 PM6/5/20
to JRimum Community
Boa tarde pessoal,
Estou tentando gerar um boleto com uma data de vencimento posterior a 21/02/2025.
Quando tento gerar retorna a seguinte mensagem de erro "Para o cálculo do fator de vencimento se faz necessário informar uma data entre 07/10/1997 e 21/02/2025.".
Eu vi que após essa data esse fator seria zerado e recomeçando de 1000 até 9999 novamente. (http://www.abbc.org.br/images/content/manual%20operacional.pdf)
Aparentemente a versão que utilizo ainda não previa esse cenário.
Utilizo a versão 0.2.3.
Gostaria de saber se existe alguma versão mais recente que este cenário já está previsto.
Em caso negativo, posso estar enganado, mas o projeto está parado, existe algum repositório que possa baixar o fonte e realizar as modificações necessárias?

Solerman Kaplon

unread,
Jun 8, 2020, 2:57:36 PM6/8/20
to jrimum-c...@googlegroups.com
Às 16:53 de 04/06/2020, Carlos Backup escreveu:
> Utilizo a versão 0.2.3.
> Gostaria de saber se existe alguma versão mais recente que este cenário já
> está previsto.
> Em caso negativo, posso estar enganado, mas o projeto está parado, existe
> algum repositório que possa baixar o fonte e realizar as modificações necessárias?


No github tem um espelho dos fontes e acho que aqui é o mais atualizado:
https://github.com/braully/bopepo


Solerman

Carlos Backup

unread,
Jun 8, 2020, 4:22:41 PM6/8/20
to JRimum Community
Solerman,
No fonte contido no link do github a classe FatorDeVencimento mantém a restrição do vencimento até fevereiro de 2025.
Eu precisaria ajustar essa classe para emitir boletos após fevereiro de 2025.
Eu tentei compilar o projeto via netbens e não obtive êxito.
Preciso editar o pom? Ou só consigo compilar via Eclipse?

Solerman Kaplon

unread,
Jun 8, 2020, 4:41:46 PM6/8/20
to jrimum-c...@googlegroups.com
Tentei clonar o projeto, dar um cd na pasta e rodei o ./sh/compile.sh e compilou de primeira no meu linux, que erro deu ao tentar compilar?
--
--
Você recebeu esta mensagem porque está inscrito no Grupo "JRimum
Community" nos Grupos do Google.
Para postar neste grupo, envie um e-mail para
jrimum-c...@googlegroups.com
ANTES DE POSTAR... leia:
https://groups.google.com/d/topic/jrimum-community/ULU8QHHgaBs/discussion
Para cancelar a sua inscrição neste grupo, envie um e-mail para
jrimum-communi...@googlegroups.com
Para ver mais opções, visite este grupo em
http://groups.google.com/group/jrimum-community?hl=pt-BR?hl=pt-BR

---
Você recebeu essa mensagem porque está inscrito no grupo "JRimum Community" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para jrimum-communi...@googlegroups.com.
Para ver essa discussão na Web, acesse https://groups.google.com/d/msgid/jrimum-community/8c55cab1-3054-4b09-afdc-293a7e55f014o%40googlegroups.com.


Carlos Backup

unread,
Jun 8, 2020, 5:19:41 PM6/8/20
to JRimum Community
No Windows/Netbeans
Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5: Could not transfer artifact org.apache.maven.plugins:maven-resources-plugin:pom:2.5 from/to central (http://repo.maven.apache.org/maven2): Failed to transfer file: http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-resources-plugin/2.5/maven-resources-plugin-2.5.pom. Return code is: 501 , ReasonPhrase:HTTPS Required. -> [Help 1]

Para ver mais opções, visite este grupo em
http://groups.google.com/group/jrimum-community?hl=pt-BR?hl=pt-BR

---
Você recebeu essa mensagem porque está inscrito no grupo "JRimum Community" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para jrimum-c...@googlegroups.com.

Solerman Kaplon

unread,
Jun 9, 2020, 7:05:37 AM6/9/20
to jrimum-c...@googlegroups.com

Você precisa um maven mais novo, baixe do site e informe nas opções do netbeans para usar o baixado.

Para ver mais opções, visite este grupo em
http://groups.google.com/group/jrimum-community?hl=pt-BR?hl=pt-BR

---
Você recebeu essa mensagem porque está inscrito no grupo "JRimum Community" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para jrimum-communi...@googlegroups.com.
Para ver essa discussão na Web, acesse https://groups.google.com/d/msgid/jrimum-community/df5b6914-dcac-40e1-80d5-881fe1083bcdo%40googlegroups.com.


Reply all
Reply to author
Forward
0 new messages