Project Compilation fails when switched to Java 11

53 views
Skip to first unread message

R. S. Patil

unread,
Aug 6, 2020, 5:18:12 AM8/6/20
to jOpenDocument
Hello,

I have been using jOpenDocument since long time to generate ods export of dataset in form of arraylist and worked great on Java 7, 6, 7 and 8.
Currently we are migrating project to Java 11 in the process we noticed that jOpenDocument failes to compile since it has embeded package
org.w3c.dom which is now part of JRE and Java 11 dont allow package name to be used at any other place.

Do you have any plans to release any updates to take care of that ?

My pom entry for jOpenDocument is as follows.

<dependency>
<groupId>org.jopendocument</groupId>
<artifactId>jOpenDocument</artifactId>
<version>1.3</version>
<!-- 
  <exclusions>
<exclusion>
<groupId>xml-apis</groupId>
<artifactId>xml-apis</artifactId>
</exclusion>
</exclusions> -->
</dependency>

I have tried exclusion of xml-apis but still project wont compile and eclipse keeps on showing package error for org.w3c.dom.

Hope you extend help in this regard.

Thanks and warm regards

R. S. Patil

Guillaume Maillard

unread,
Aug 6, 2020, 5:22:05 AM8/6/20
to jopend...@googlegroups.com
Hi,

We are working on a new website for jOpenDocument and will will provide packages for the case you mentioned.
For now, we provide such custom packages for companies having commercial licence & active support.

Regards,

Guillaume

--

---
You received this message because you are subscribed to the Google Groups "jOpenDocument" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jopendocumen...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/jopendocument/a27a5958-b344-439e-9dd9-f4331cef5cc0o%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages