jGnash 2.36.0 has been released

1 view
Skip to first unread message

Craig Cavanaugh

unread,
Sep 16, 2018, 8:33:33 AM9/16/18
to jgnas...@googlegroups.com, Google jGnash Devel Group
jGnash 2.36.0 has been released.
Upgrading is recommend.

jGnash is available from the usual download location.  https://sourceforge.net/projects/jgnash/files/latest/download  

This releases is mostly a bug fix release for use of portable preferences and includes a MT940 import enhancement from Alex Werz.

Command line processing was improved with support in the old Swing interface depreciated.

Also, many releases ago, some old support code was removed that addressed some very old file corruption issues.  What I'm finding is some folks have skipped past releases and this has created issues.  I've reinstated the old support code to correct the old corruption issues.

The detailed list of changes is below.

Thanks,
Craig

Release 2.36.0
* 09/13/2018 Enhanced the MT940 parser to allow for an optional currency designator in decimal values. (Swing, Fx) _[Alex Werz]_
* 09/13/2018 Reinstated check and correct for data files with multiple root accounts and config objects. (Swing, Fx)
* 09/13/2018 The Fx interface now uses picocli for command line processing. (Fx)
* 09/13/2018 The old Swing interface no longer supports command line processing. (Swing)
* 09/10/2018 Fixed a bug that was preventing initialization of a new user specified portable preference file. (Fx)
* 09/09/2018 Fixed a random stability issue with client / server operation discovered during unit testing. (Swing, Fx)
* 09/09/2018 Updated to the latest Apache POI dependency.
* 09/09/2018 Updated manual with proper use of escape characters on the command line for file names.
* 09/06/2018 Dropped use of log4j as it is no longer a needed dependency.

pran...@gmail.com

unread,
Sep 17, 2018, 5:45:28 AM9/17/18
to jgnas...@googlegroups.com, Google jGnash Devel Group
Hi Craig et all,
I am still having trouble trying to upgrade to this version and wonder if anyone can help/suggest ideas.

(a) I complete removed Java from my system (MacOS 10.13.6) and install JDK build 1.8.0_181-b13
(b) jGnashFx 2.34.1 is happily running. File format is .bxds

Tried running v2.36.0 jGnashFx
* UI starts with the last message on command line "[2018-09-17 17:41:44] [INFO   ] {jgnash.uifx.views.main.MainView lambda$checkForLatestRelease$9} Version check performed"
* I open my bxds file but the loading overlay shows for 1-2 seconds and nothing else happens. No change if I run with "-v" on the command line

Tried running v2.36.0 jGnash2
* UI starts fine
* When I load my file the following popup appears
error.png


Regards
Pranay


--
You received this message because you are subscribed to the Google Groups "jGnash-User" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jgnash-user...@googlegroups.com.
To post to this group, send email to jgnas...@googlegroups.com.
Visit this group at https://groups.google.com/group/jgnash-user.
For more options, visit https://groups.google.com/d/optout.

pran...@gmail.com

unread,
Sep 21, 2018, 11:26:35 PM9/21/18
to jgnas...@googlegroups.com, Google jGnash Devel Group
Craig,
Exported to XML and opened in an editor. Found that one of the UUIDs on a security node is corrupted. See attached.

Questions:
(1) Can I just edit the XML to replace this with a valid UUID and the rest will match up?
(2) Are you using this UUID for any other cross reference? I see a lot of "id" cross references but not sure if you also use UUID

regards
Pranay

xml.jpg

pran...@gmail.com

unread,
Sep 29, 2018, 4:56:40 AM9/29/18
to Craig Cavanaugh, Google jGnash Devel Group
I decided to go ahead with the UUID replacement as everything seems to work. I could not find the original broken UUID anywhere else in the XML so assumed there was only one place to replace.

- Pranay
Reply all
Reply to author
Forward
0 new messages