Declarative multibranch pipeline: StackOverflowException after trying to specify agent label

100 views
Skip to first unread message

ST

unread,
Jun 10, 2017, 4:52:28 PM6/10/17
to Jenkins Users
I'm getting StackOverflowException when trying to open the folder of my multibranch pipeline job, see below for first part of the stacktrace.

The pipeline is defined in declarative job dsl and has worked fine so far. This SOE occurred now after I've changed in my pipeline from
pipeline {
  agent any
 [...]
}

to 

pipeline {
  agent {
    label 'test'
  }
 [...]
}

So my guess is that this must somehow have triggered the SOE? I've now reverted the pipeline script to 'agent any' but still getting the SOE below.

My jenkins instance: Jenkins 2.64 with latest pipeline plugins. The other build agent (with label 'test') is a remote ssh agent and has successfully built other (freestyle) projects. This was my first attempt to build a pipeline on that agent.

Any permission that I need to set, or any other ideas what could be wrong? I can file a jira issue, but trying to understand what's happening first.
java.lang.StackOverflowError
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)
	at org.jenkinsci.plugins.workflow.multibranch.BranchJobProperty$1.hasPermission(BranchJobProperty.java:77)

Dan Tran

unread,
Jun 10, 2017, 6:51:15 PM6/10/17
to Jenkins Users, st.mail...@gmail.com
did happen to me due to plugin upgrade, either dashboard or monitor. ended up to revert both and  drop the mulit branch (set the repo scanner to xxx) and recreate again ( put scanner back to .*)

did you upgrade?

-Dan

must drop the job since your job config.xml is corrupted with tons of weidr entries relate to the log

ST

unread,
Jun 11, 2017, 3:46:01 AM6/11/17
to Dan Tran, Jenkins Users
Yes I upgraded some plugins and restarted jenkins a few hours before this happened. But after that several builds of this job went fine, so I'm thinking it must be something else that has triggered the SOE.

Changing the agent declaration in the pipeline script I did using the "Replay" function, which could also be the reason for the SOE. Will test dropping those builds first, and if that doesnt help try to drop whole job and/or downgrade plugins.

ST

unread,
Jun 11, 2017, 8:12:46 AM6/11/17
to Dan Tran, Jenkins Users
FYI: Downgrading didn't help, not sure what you mean by "dashboard or monitor". The only similar plugin names I've installed are
  • "Dashboard for Blue Ocean" plugin 1.0.1
  • "External Monitor Job Type Plugin" 1.7
And downgrading them to previous version didnt help.

Andrew Bayer

unread,
Jun 11, 2017, 10:12:05 AM6/11/17
to Dan Tran, jenkins...@googlegroups.com
So this ended up being an actual bug in Declarative. Sigh. Working on it.

A.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-use...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CABwQARsC7eYEKm62mCun8w7azbAAXBO%3D-bJVbeXNOtokD0wzfg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Dan Tran

unread,
Jun 12, 2017, 12:46:31 AM6/12/17
to Jenkins Users, dan...@gmail.com
looking forward for a fix. The issue comes back to our Jenkins

@Andrew, you have a list of plugins we can use the downgrade back?

-Dan

Dan Tran

unread,
Jun 12, 2017, 2:14:39 AM6/12/17
to Jenkins Users, dan...@gmail.com
here is the list to downgrade

pipeline model definition
pipeline declarative extention point
pipeline model api
pipeline stage tags metadata

1.1.5  back to 1.1.4

Andrew Bayer

unread,
Jun 12, 2017, 5:53:54 PM6/12/17
to jenkins...@googlegroups.com, Dan Tran
Or just install the now-released 1.1.6. Everything does have to build to get fixed, but you can bypass that by running the script at https://issues.jenkins-ci.org/browse/JENKINS-44809?focusedCommentId=302837&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-302837 in the Jenkins Script Console.

A.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/d548c257-abd4-4f00-bc51-256e1fede912%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages