Still stuck on older Jenkins because of table-to-div -- what to do?

30 views
Skip to first unread message

Roland Asmann

unread,
Jun 4, 2021, 6:51:46 AMJun 4
to Jenkins Users

Hi all,

Because of the table-to-div changes in 2.277.1 not working in several plugins, I am still running 2.263.4.  Every time I check the list of known plugins that aren't working since this update, the list seems to grow...
A different change in Jenkins a couple of years back made us setup a second Jenkins instance, because of projects that weren't able run on the new version. I am still migrating some of those projects and I really don't want to setup a 3rd instance and maintain all 3.

So, how do I proceed? Can someone 'force' the plugin developers to update their plugins? Or maybe someone can look some of the plugins over and get them running again?

And maybe it would be good if someone could check over all open issues in this list (https://issues.jenkins.io/secure/Dashboard.jspa?selectPageId=20741) and see if they are actually still existing/are referencing the correct plugin -- some issues were created saying it was an issue in the core, but the comments later state it was actually a plugin. I really need to know if there are still issues in the core or if it's only in some plugins, so I can decide on how to move on...

Thanks.

Roland

Ullrich Hafner

unread,
Jun 4, 2021, 7:44:21 AMJun 4
to Jenkins Users
Am 04.06.2021 um 12:51 schrieb Roland Asmann <roland...@gmail.com>:


Hi all,

Because of the table-to-div changes in 2.277.1 not working in several plugins, I am still running 2.263.4.  Every time I check the list of known plugins that aren't working since this update, the list seems to grow...
A different change in Jenkins a couple of years back made us setup a second Jenkins instance, because of projects that weren't able run on the new version. I am still migrating some of those projects and I really don't want to setup a 3rd instance and maintain all 3.

So, how do I proceed? Can someone 'force' the plugin developers to update their plugins?

No. If a plugin does not yet support 2.277.1 then the plugin is probably not maintained at all anymore. Then it would help if someone who still uses the plugin would volunteer to take over the ownership. This is how our open source model in Jenkins works. 

Or maybe someone can look some of the plugins over and get them running again?


See above. We do not have a support policy for plugins, so if something does not work and the maintainer has no spare time to fix then it is up to the community to help here.

And maybe it would be good if someone could check over all open issues in this list (https://issues.jenkins.io/secure/Dashboard.jspa?selectPageId=20741) and see if they are actually still existing/are referencing the correct plugin -- some issues were created saying it was an issue in the core, but the comments later state it was actually a plugin. I really need to know if there are still issues in the core or if it's only in some plugins, so I can decide on how to move on...

Thanks.

Roland

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-use...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/ff4acd22-e8c5-4dc7-8284-645c5c1375d6n%40googlegroups.com.

Baptiste Mathus

unread,
Jun 7, 2021, 4:11:49 AMJun 7
to jenkins...@googlegroups.com
Hi Roland,

Ulli summarized the situation very well.

If you can consider providing a more specific list of plugins that you're waiting on, we can probably point you to the right path to get them fixed (become maintainer, pay someone to fix them, etc.).
(very personal) rule of thumb: if the plugin has less than ~2 to 3k installs worldwide, there's close to zero chance that somebody steps up if you do not.

Cheers  

Roland Asmann

unread,
Jun 9, 2021, 4:50:49 PMJun 9
to jenkins...@googlegroups.com
Hi,

The only plugin I am sure of, is the performance-plugin, since I
reported that one myself. It shouldn't be dead, since they merged a PR
of mine and built a release about a week prior to me reporting this issue...

Anyway, I looked into this plugin, but I can't for the life of me figure
out how to layout a part of the form as a table -- since imo a part of
the form *should* be a table. I'll see if I can find some time to give
it another look, but I wouldn't mind if someone gave the current owner a
little nudge either... :-)

As for the other plugins, the list that is found here
(https://issues.jenkins.io/secure/Dashboard.jspa?selectPageId=20741)
doesn't have any other plugins that I have installed. It does however
have some entries that say they affect the core, which in some instances
is then disproved by others -- same with some of the plugins though...
Since the original authors didn't come back to report on whether or not
the issue is solved, I feel kind of lost on the actual status....
Maybe someone can look over the issues that are have component 'core'
set and correct the component/close the issue?

Thanks.

Roland

On 06.06.2021 16:10, Baptiste Mathus wrote:
> Hi Roland,
>
> Ulli summarized the situation very well.
>
> If you can consider providing a more specific list of plugins that
> you're waiting on, we can probably point you to the right path to get
> them fixed (become maintainer, pay someone to fix them, etc.).
> (very personal) rule of thumb: if the plugin has less than ~2 to 3k
> installs worldwide, there's close to zero chance that somebody steps up
> if you do not.
>
> Cheers
>
> Le ven. 4 juin 2021 à 13:44, Ullrich Hafner <ullrich...@gmail.com
> <mailto:ullrich...@gmail.com>> a écrit :
>
>> Am 04.06.2021 um 12:51 schrieb Roland Asmann
>> <roland...@gmail.com <mailto:roland...@gmail.com>>:
>>
>>
>> Hi all,
>>
>> Because of the table-to-div changes in 2.277.1 not working in
>> several plugins, I am still running 2.263.4.  Every time I check
>> the list of known plugins that aren't working since this update,
>> the list seems to grow...
>> A different change in Jenkins a couple of years back made us setup
>> a second Jenkins instance, because of projects that weren't able
>> run on the new version. I am still migrating some of those
>> projects and I really don't want to setup a 3rd instance and
>> maintain all 3.
>>
>> So, how do I proceed? Can someone 'force' the plugin developers to
>> update their plugins?
>
> No. If a plugin does not yet support 2.277.1 then the plugin is
> probably not maintained at all anymore. Then it would help if
> someone who still uses the plugin would volunteer to take over the
> ownership. This is how our open source model in Jenkins works.
>
>> Or maybe someone can look some of the plugins over and get them
>> running again?
>>
>
> See above. We do not have a support policy for plugins, so if
> something does not work and the maintainer has no spare time to fix
> then it is up to the community to help here.
>
>> And maybe it would be good if someone could check over all open
>> issues in this list
>> (https://issues.jenkins.io/secure/Dashboard.jspa?selectPageId=20741 <https://issues.jenkins.io/secure/Dashboard.jspa?selectPageId=20741>)
>> and see if they are actually still existing/are referencing the
>> correct plugin -- some issues were created saying it was an issue
>> in the core, but the comments later state it was actually a
>> plugin. I really need to know if there are still issues in the
>> core or if it's only in some plugins, so I can decide on how to
>> move on...
>>
>> Thanks.
>>
>> Roland
>>
>> --
>> You received this message because you are subscribed to the Google
>> Groups "Jenkins Users" group.
>> To unsubscribe from this group and stop receiving emails from it,
>> send an email to jenkinsci-use...@googlegroups.com
>> <mailto:jenkinsci-use...@googlegroups.com>.
>> <https://groups.google.com/d/msgid/jenkinsci-users/ff4acd22-e8c5-4dc7-8284-645c5c1375d6n%40googlegroups.com?utm_medium=email&utm_source=footer>.
>
> --
> You received this message because you are subscribed to the Google
> Groups "Jenkins Users" group.
> To unsubscribe from this group and stop receiving emails from it,
> send an email to jenkinsci-use...@googlegroups.com
> <mailto:jenkinsci-use...@googlegroups.com>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/jenkinsci-users/C6997362-A032-4300-B131-9E70A953CDE5%40gmail.com
> <https://groups.google.com/d/msgid/jenkinsci-users/C6997362-A032-4300-B131-9E70A953CDE5%40gmail.com?utm_medium=email&utm_source=footer>.
>
> --
> You received this message because you are subscribed to a topic in the
> Google Groups "Jenkins Users" group.
> To unsubscribe from this topic, visit
> https://groups.google.com/d/topic/jenkinsci-users/km6T7yk4d-Y/unsubscribe <https://groups.google.com/d/topic/jenkinsci-users/km6T7yk4d-Y/unsubscribe>.
> To unsubscribe from this group and all its topics, send an email to
> jenkinsci-use...@googlegroups.com
> <mailto:jenkinsci-use...@googlegroups.com>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/jenkinsci-users/CANWgJS7_rqvdRagHHmBHy%3DVU2185ZDJMZ6qhpjC7R6%3DnhbhcMg%40mail.gmail.com
> <https://groups.google.com/d/msgid/jenkinsci-users/CANWgJS7_rqvdRagHHmBHy%3DVU2185ZDJMZ6qhpjC7R6%3DnhbhcMg%40mail.gmail.com?utm_medium=email&utm_source=footer>.

--
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

Reply all
Reply to author
Forward
0 new messages