Unable to Install or Update - Debian/Ubuntu

37 views
Skip to first unread message

Scott Duensing

unread,
Dec 10, 2021, 2:58:32 PM12/10/21
to Jenkins Users
 After adding the key and repository, I receive the following:

Ign:4 https://pkg.jenkins.io/debian-stable binary/ InRelease
Err:5 https://pkg.jenkins.io/debian-stable binary/ Release
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 151.101.2.133 443]

Mark Waite

unread,
Dec 10, 2021, 3:02:34 PM12/10/21
to Jenkins Users
That may indicate that the base operating system has not been updated and so is not ready for the Let's Encrypt SSL certificate that is used on pkg.jenkins.io.

Update the operating system packages to the latest package versions.  See https://www.debian.org/doc/manuals/debian-faq/uptodate.en.html for guidance on Debian.

Mark Waite

Scott Duensing

unread,
Dec 14, 2021, 2:00:43 PM12/14/21
to Jenkins Users
Dang.  I must have been asleep at the wheel.  That's all it was.  Thanks!
Reply all
Reply to author
Forward
0 new messages