[Jacoco Plugin] Code Coverage Trend by executing jacoco.exec shows 0% coverage, HTML,csv and xml outputs shows code coverage statistics

50 views
Skip to first unread message

yash sharma

unread,
Mar 11, 2019, 4:07:34 AM3/11/19
to Jenkins JaCoCo plugin mailing list
Hi All,

I am using Jenkins ver. 1.623 and Jacoco Plugin cer. 1.0.8.
I have configured Post-Build Action to show Jacoco coverage report


Post build I could see the following logs
BUILD SUCCESSFUL
Total time: 1 minute 49 seconds
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=384m; support was removed in 8.0
[JaCoCo plugin] Collecting JaCoCo coverage data...
[JaCoCo plugin] **/testclasses/*.exec, **/test/*.exec;**/testclasses/classes, **/test/classes;**/cotplus-web,**/cotplus-services; locations are configured
[JaCoCo plugin] Number of found exec files: 2
[JaCoCo plugin] Saving matched execfiles:  C:\Users\604785747\Pictures\cotplus-source\Construction\cotplus-services\test\jacoco.exec C:\Users\604785747\Pictures\cotplus-source\Construction\cotplus-web\testclasses\jacoco.exec
[JaCoCo plugin] Saving matched class directories:  C:/Users/604785747/Pictures/cotplus-source\Construction\cotplus-web\testclasses\classes
[JaCoCo plugin] Saving matched source directories:  C:/Users/604785747/Pictures/cotplus-source\Construction\cotplus-services C:/Users/604785747/Pictures/cotplus-source\Construction\cotplus-services\dist\cotplus-services C:/Users/604785747/Pictures/cotplus-source\Construction\cotplus-web C:/Users/604785747/Pictures/cotplus-source\Construction\cotplus-web\build\ivy-cache\bt\cotplus-services C:/Users/604785747/Pictures/cotplus-source\Deliverables\components\cotplus-services C:/Users/604785747/Pictures/cotplus-source\Deliverables\wars\cotplus-web
[JaCoCo plugin] Loading EXEC files..
[JaCoCo plugin] Publishing the results..
[JaCoCo plugin] Loading packages..
[JaCoCo plugin] Done.
Finished: SUCCESS

and I could see the HTML, xml and csv files resulting from Jacoco Junit build showing proper data. PFB the HTML output



But the Code Coverage Report shows 0% coverage.



Is there an issue with the version I am using ?
Thanks in advance for any help to sort this issue out.
Best Regards
Yash

Dominik Stadler

unread,
Mar 11, 2019, 5:17:30 PM3/11/19
to jenkins-jacoco-pl...@googlegroups.com
Both Jenkins and Jacoco-plugin have a much newer version (JaCoCo-plugin 3.0.4 requires Jenkins 2.54 or newer) which contain numerous bug-fixes, so you probably should verify with a more recent version if the problem still exists there.

Dominik.

--
Azért kapta ezt az üzenetet, mert feliratkozott a Google Csoportok „Jenkins JaCoCo plugin mailing list” csoportjára.
Az erről a csoportról és az ahhoz kapcsolódó e-mailekről való leiratkozáshoz küldjön egy e-amailt a(z) jenkins-jacoco-plugin-m...@googlegroups.com címre.
Ha üzenetet szeretne küldeni ebbe a csoportba, küldjön e-mailt a(z) jenkins-jacoco-pl...@googlegroups.com címre.
További lehetőségekért látogasson el ide: https://groups.google.com/d/optout.

Avec

unread,
Nov 15, 2019, 10:57:33 AM11/15/19
to Jenkins JaCoCo plugin mailing list
Also I do not think 3.0.4 supports higher than java 10 (since 3.0.3). I did find a referende to Java 11 in the 3.0.4 Jenkins source file but have not testet it. 
I for sure does not work with Java 13. 

-Avec
Reply all
Reply to author
Forward
0 new messages