Invalid caracter

17 views
Skip to first unread message

Sérgio Uetanabaro

unread,
Apr 15, 2016, 8:06:03 AM4/15/16
to jec users
Hello,

I got trial version to do some tests but i got problem. When i try to read mailbox using method "getEmailsShallow" im getting "invalid caracter 0x 7" throwing by xerces. Analysing returned XML i got this fragment:

<t:Message>
<t:ItemId ChangeKey="xxxxxxxx" Id="xxxxxx"/>
<t:ItemClass>IPM.Note</t:ItemClass>
<t:Subject>Arquivos de Conhecimento de Transporte Eletronico (1-1/1)</t:Subject>
<t:Sensitivity>Normal</t:Sensitivity>
<t:DateTimeReceived>2016-04-12T09:11:55Z</t:DateTimeReceived>
<t:Importance>Normal</t:Importance>
<t:DisplayCc/>
<t:DisplayTo>CT-e; xx...@xxxx.com</t:DisplayTo>
<t:HasAttachments>true</t:HasAttachments>
<t:From>
<t:Mailbox>
<t:Name>XXXXX Solu[0x7][0x5]es em Log[\r]stica</t:Name>
<t:EmailAddress>xxx...@xxxxx.com</t:EmailAddress>
<t:RoutingType>SMTP</t:RoutingType>
</t:Mailbox>
</t:From>
<t:IsRead>false</t:IsRead>
</t:Message>


I dont know how exchange do this but i cant receive my tests emails. How can i proceed to work around it?


Tks


jonathan sanders

unread,
Apr 15, 2016, 8:19:28 AM4/15/16
to uetanab...@gmail.com, jec users2
Please send me (only me, not the forum) your full debug log (as an attachment) and test code.

Please change the log4j.properties, located at the lib directory to:

----------------------
log4j.rootLogger=WARN
log4j.appender.stdout=org.apache.log4j.ConsoleAppender
log4j.appender.stdout.layout=org.apache.log4j.PatternLayout
log4j.appender.stdout.layout.ConversionPattern=%5p [%c] %m%n
log4j.category.jec.utils.AppLogger=DEBUG, stdout
log4j.logger.httpclient.wire=DEBUG, stdout
log4j.logger.jec.httpclient3=DEBUG, stdout
---------------------

Please send me your full debug log (as an attachment) and test code.


--
You received this message because you are subscribed to the Google Groups "jec users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jec-users2+...@googlegroups.com.
To post to this group, send email to jec-u...@googlegroups.com.
Visit this group at https://groups.google.com/group/jec-users2.
For more options, visit https://groups.google.com/d/optout.



--
Best Regards,
Jonathan Sanders,
Developer & Support Eng,
NetComps LTD
Message has been deleted
Message has been deleted

Sérgio Uetanabaro

unread,
May 30, 2016, 12:31:01 PM5/30/16
to jec users
I'm still having same problems with last version downloaded from https://drive.google.com/file/d/0B2aT0QoEmtuaampmLS0yQmduLUU/view






On Friday, April 15, 2016 at 9:06:03 AM UTC-3, Sérgio Uetanabaro wrote:
Hello,

I got trial version to do some tests but i got problem. When i try to read mailbox using method "getEmailsShallow" im getting "invalid caracter 0x 7" throwing by xerces. Analysing returned XML i got this fragment:

<t:Message>
<t:ItemId ChangeKey="xxxxxxxx" Id="xxxxxx"/>
<t:ItemClass>IPM.Note</t:ItemClass>
<t:Subject>Arquivos de Conhecimento de Transporte Eletronico (1-1/1)</t:Subject>
<t:Sensitivity>Normal</t:Sensitivity>
<t:DateTimeReceived>2016-04-12T09:11:55Z</t:DateTimeReceived>
<t:Importance>Normal</t:Importance>
<t:DisplayCc/>
<t:DisplayTo>CT-e; xx...@xxxx.com</t:DisplayTo>
<t:HasAttachments>true</t:HasAttachments>
<t:From>
<t:Mailbox>
<t:Name>XXXXX Solu[0x7][0x5]es em Log[\r]stica</t:Name>
<t:EmailAddress>xxxxxxl@xxxxx.com</t:EmailAddress>
<t:RoutingType>SMTP</t:RoutingType>
</t:Mailbox>
</t:From>
<t:IsRead>false</t:IsRead>
</t:Message>

jonathan sanders

unread,
May 30, 2016, 2:15:44 PM5/30/16
to jec users2

It does not reproduce to me, what is your version number?

Best Regards,
Jonathan Sanders,
NetComps LTD

On May 30, 2016 19:31, "Sérgio Uetanabaro" <uetan...@hotmail.com> wrote:
I'm still having same problems with last version downloaded from https://drive.google.com/file/d/0B2aT0QoEmtuaampmLS0yQmduLUU/view






On Friday, April 15, 2016 at 9:06:03 AM UTC-3, Sérgio Uetanabaro wrote:
Hello,

I got trial version to do some tests but i got problem. When i try to read mailbox using method "getEmailsShallow" im getting "invalid caracter 0x 7" throwing by xerces. Analysing returned XML i got this fragment:

<t:Message>
<t:ItemId ChangeKey="xxxxxxxx" Id="xxxxxx"/>
<t:ItemClass>IPM.Note</t:ItemClass>
<t:Subject>Arquivos de Conhecimento de Transporte Eletronico (1-1/1)</t:Subject>
<t:Sensitivity>Normal</t:Sensitivity>
<t:DateTimeReceived>2016-04-12T09:11:55Z</t:DateTimeReceived>
<t:Importance>Normal</t:Importance>
<t:DisplayCc/>
<t:DisplayTo>CT-e; xx...@xxxx.com</t:DisplayTo>
<t:HasAttachments>true</t:HasAttachments>
<t:From>
<t:Mailbox>
<t:Name>XXXXX Solu[0x7][0x5]es em Log[\r]stica</t:Name>
<t:EmailAddress>xxx...@xxxxx.com</t:EmailAddress>
<t:RoutingType>SMTP</t:RoutingType>
</t:Mailbox>
</t:From>
<t:IsRead>false</t:IsRead>
</t:Message>


I dont know how exchange do this but i cant receive my tests emails. How can i proceed to work around it?


Tks


Sérgio Uetanabaro

unread,
May 31, 2016, 10:07:43 AM5/31/16
to jec users

ewsj2.13_08

jonathan sanders

unread,
May 31, 2016, 1:03:23 PM5/31/16
to jec users2
Hmm,
You are using the latest version.
Since it does not reproduce to me in the normal ways, the only way I see I can try to reproduce it is to connect to a test account which have this issue.
If you can, create a test account to me, with this email, and I will try to reproduce it.
Reply all
Reply to author
Forward
0 new messages