jedi/jazz compile fails

Skip to first unread message

Sandeep Puri

Dec 30, 2011, 10:05:22 PM12/30/11
to Jazz Scheme
it fails at jazz.git

with the following error
make jazz.git
; compiling jazz/git/foreign...
foreign.c:13911:18: error: git2.h: No such file or directory

any help would be appreciated..
I tried this on mac osx with libgit2 installed as part of macports..
same error on linux, ubuntu 11 64 bit ..

It seems the jazz.git product is not picking up git2.h header files..


Jan 1, 2012, 12:39:55 AM1/1/12
to Jazz Scheme
Modules that link to external unit require custom build.
jazz.git.product only has the windows branch defined. The easy
solution is to comment out that module.

(module protected jazz.git.foreign jazz

@wait (

Guillaume Cartier

Jan 1, 2012, 10:11:31 PM1/1/12
to Jazz Scheme
The problem is fixed. Commit: "Fixed compilation problem on non-
Windows platforms due to new libgit2 interface"

We started work on Windows on interfacing libgit2 and forgot to put
Windows specific code in a cond-expand. Thanks for spotting that.

PS: Making the code multi-platform is probably a 15mn job if anybody
needs to interface libgit2 on a non-Windows platform.

PPS: I didn't have access to a Mac platform to test the fix...


On Dec 30 2011, 10:05 pm, Sandeep Puri <> wrote:


Feb 4, 2012, 7:51:21 PM2/4/12
to Jazz Scheme
Thanks for the quick response, but

Still fails for me at

make jazz.ide
; compiling jazz/ide/_ide...
Walk problems encountered
In jazz.database.ado.connection.ADODB
Unresolved symbol: HRESULT
Unresolved symbol: HRESULT

I deleted my jedi directory. Recloned the code. ran ./jam, then
%make in jam, and that's what I got.



Feb 7, 2012, 1:31:08 AM2/7/12
to Jazz Scheme
Thanks for the quick reply, but it still fails on me at the same place
as before.

I did succeed in installing OK on a windows machine, but would rather
work on linux.


On Jan 1, 7:11 pm, Guillaume Cartier <> wrote:
Reply all
Reply to author
0 new messages