Dynamic Compilation and Railo 4 Tomcat on Windows missing JavaCompiler

58 views
Skip to first unread message

Adrian Black

unread,
Jul 20, 2013, 6:32:00 PM7/20/13
to javaloa...@googlegroups.com
Hi
I have been trying to get dynamic compilation working on Railo 4.x
Railo seems to come with Java 1.7.x and is marked as the /railo/jdk so im assuming it is a jdk but there is no tools.jar.
 
As soon as I specify sourceDirectories i get the below

Application Execution Exception

Error Type: javaCompiler.NoCompilerAvailableException : [N/A]
Error Messages: No Java Compiler is available
There is no Java Compiler available. Make sure tools.jar is in your classpath and you are running Java 1.6+

There is no tools.jar in the railo distribution and i have the production and not the express.
I have tried to change the railo/jdk for an actual jdk version and put the tools.jar in C:\railo\lib\railo-server\context\lib but nothing worked.

Just not doable?


Thanks

Mark Mandel

unread,
Jul 21, 2013, 8:49:40 PM7/21/13
to javaloa...@googlegroups.com
In theory it should be... if the tools.jar is in the classpath and you reboot your server.

But I don't think I ever tested it on Railo TBH.

Mark


--
You received this message because you are subscribed to the Google Groups "javaloader-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to javaloader-de...@googlegroups.com.
To post to this group, send email to javaloa...@googlegroups.com.
Visit this group at http://groups.google.com/group/javaloader-dev.
For more options, visit https://groups.google.com/groups/opt_out.
 
 



--
E: mark....@gmail.com
T: http://www.twitter.com/neurotic
W: www.compoundtheory.com

2 Devs from Down Under Podcast

Adrian Black

unread,
Jul 22, 2013, 5:52:03 AM7/22/13
to javaloa...@googlegroups.com
Thanks Mark. 
I think we are seeing Mark Drew next week so will i will ask him if it is a jdk and why the tools.jar isnt there if it is and if he has a solution.

Reply all
Reply to author
Forward
0 new messages