Arquivo .jasper não atualiza

763 views
Skip to first unread message

Rafael Ferraro

unread,
Feb 26, 2013, 11:48:23 AM2/26/13
to jasperreports-...@googlegroups.com
Olá pessoal, boa tarde.
Estou enfrentando um sério problema aqui na empresa, tenho um relatório que precisa ser alterado, ou melhor, preciso incrementar dados ao mesmo. Esta acontecendo o seguinte fato: Primeiro eu tentava fazer alterações de layout no relatório como incluir um campo texto, um retângulo, etc, MAS, o arquivo .jasper não atualizava de forma alguma. Depois de muitos testes, alterei o compilador do ireport e consegui atualizar. Até ai beleza. O Problema agora, com O MESMO RELATÓRIO, é que preciso criar um campo recuperando um dado do banco de dados, ou seja, tenho que acrescentar um campo em minha query no ireport. Porém acontece o mesmo erro que vinha acontecendo com o layout, o arquivo .jasper não atualiza de forma alguma, já alterei compilador, mudei opções, fiz de tudo, mas nada, o .jasper não atualiza quando faço alterações em minha query. O mais curioso de tudo é que isso ocorre apenas neste relatório, os outros relatórios sofrem alterações normalmente. Os arquivos .bak e .jrxml atualizam corretamente, já o .jasper não . Uso o  ireport 3.0.0 !
Desde já agradeço a ajuda de vocês, a tempos venho procurando uma solução e não encontro nada ! Obrigado !

Roberley Cristiano

unread,
Feb 26, 2013, 2:05:20 PM2/26/13
to jasperreports-...@googlegroups.com
Boa tarde

tenta verificar onde ele esta gerando o arquivo se tem alguma restrição de permissão no diretorio, uma vez tive este problema no linux.

Att
Cristiano


--
Você está recebendo esta mensagem porque se inscreveu no grupo "JasperReports / iReport Brasil" dos Grupos do Google.
Para cancelar a inscrição neste grupo e parar de receber seus e-mails, envie um e-mail para jasperreports-irepor...@googlegroups.com.
Para obter mais opções, acesse https://groups.google.com/groups/opt_out.
 
 

wellington chagas

unread,
Feb 26, 2013, 4:45:35 PM2/26/13
to jasperreports-...@googlegroups.com
Apaga ou renomeia o .jasper original pra ter certeza que ele esta conseguindo criar um novo qnd vc compila
--
                       

Oracle Certified Professional, Java SE 6 Programmer

           Bacharel em Ciência da Computação 

Rafael Ferraro

unread,
Feb 27, 2013, 11:30:57 AM2/27/13
to jasperreports-...@googlegroups.com
Cara eu exclui o arquivo, percebi que o compilador não está gerando o arquivo .jasper ! O que eu faço ? hahaha

Roberley Cristiano

unread,
Feb 27, 2013, 12:12:44 PM2/27/13
to jasperreports-...@googlegroups.com
vai no menu opções e vai no botão opções ... verifica na aba Compilador onde ele esta gerando o seu .jasper

a minha opção esta "usar o diretorio do relatorio para compilados" e tb a opção "salvar automaticamente antes de compilar"

as vezes pode ser isso.

Rafael Ferraro

unread,
Feb 27, 2013, 1:01:23 PM2/27/13
to jasperreports-...@googlegroups.com
Cristiano , as duas opções estão marcadas já, muito estranho isso pq é somente neste relatório que está ocorrendo este erro


Em terça-feira, 26 de fevereiro de 2013 13h48min23s UTC-3, Rafael Ferraro escreveu:

wellington chagas

unread,
Feb 27, 2013, 1:28:29 PM2/27/13
to jasperreports-...@googlegroups.com
Usando a dica do cristiano, desmarca a opcao "usar o diretorio do relatorio para compilados" e seleciona um diretorio manualmente como a area de trabalho por exemplo. e testa pra ver se funciona e depois e volta a marcar. Outra alternativa é copiar os arquivos para um diretorio que vc tem certeza q seu usuario tem acesso(sem nenhuma restricao do windows), como a "area de trabalho" ou "meus documentos" e tentar com a opcao "usar o diretorio do relatorio para compilados" marcada.

--
Você está recebendo esta mensagem porque se inscreveu no grupo "JasperReports / iReport Brasil" dos Grupos do Google.
Para cancelar a inscrição neste grupo e parar de receber seus e-mails, envie um e-mail para jasperreports-irepor...@googlegroups.com.
Para obter mais opções, acesse https://groups.google.com/groups/opt_out.
 
 

Rafael Ferraro

unread,
Feb 27, 2013, 2:14:06 PM2/27/13
to jasperreports-...@googlegroups.com
wellington Valeu pelas dicas cara, mas também não resolveu, se eu compilar sem ter alterado a query ele compila, agora qualquer alteração que eu faço na query ele já não gera o arquivo mais, ta foda !!!!


Em terça-feira, 26 de fevereiro de 2013 13h48min23s UTC-3, Rafael Ferraro escreveu:

Rafael Ferraro

unread,
Feb 27, 2013, 2:14:57 PM2/27/13
to jasperreports-...@googlegroups.com
Será que não tem alguma forma de limpar a memória do relatório ou do iReport sem perder as informações ?


Em terça-feira, 26 de fevereiro de 2013 13h48min23s UTC-3, Rafael Ferraro escreveu:
Message has been deleted

Denis Benjamim

unread,
Jun 13, 2019, 5:13:30 PM6/13/19
to jasperreports-...@googlegroups.com
Boa noite

IReport? Pleno 2019? Amigo hoje em dia pessoal usa JasperReports para criar e editar seus relatórios voce chegou a tentar nele? 

Em qui, 13 de jun de 2019 18:05, José Paulo <java1s...@gmail.com> escreveu:
Olá, bom dia!

Desculpem por reviver esse tópico 6 anos depois, mas eu estive passando pelo mesmo problema. Eu fazia as modificações no layout do meu arquivo jrxml, compilava para gerar o arquivo jasper, e nada. Nem mesmo fazendo o relatório do zero e compilando dava certo. Revirei o Google de cima a baixo, em vários fóruns, até em fóruns gringos, e não achei nenhuma solução.

Apenas encontrei o mesmo relato desse problema nesse grupo do Google, e no GUJ (https://www.guj.com.br/t/layout-do-ireport-nao-atualiza/140448/8), que parecem ter sido criados pela mesma pessoa.

Enfim, depois de longos 4 dias de tentativas falhas, encontrei a solução por conta própria (já que não encontrei em nenhum outro lugar), que pelo menos para mim, resolveu.

Hoje, eu uso o NetBeans 8.2 e o plugin do iReport na versão 5.6.0. Notei que na biblioteca do meu projeto, o meu jar do jasperreports estava na versão 5.0.0. Então eu o removi e adicionei o jar do jasperreports na mesma versão do meu plugin (5.6.0).
Dessa forma, compilei meu projeto e meu relatório, e testei, porém ainda não havia funcionado, mas só precisei remover outro jar que eu tinha na minha biblioteca do projeto, o jar do log4j na versão 1.2.15, pois parece que essa biblioteca já vem inclusa na versão 5.6.0 do jar do jasperreports.

Enfim, essa foi a solução que salvou meu dia. Estou postando aqui para que fique registrado, pois eu não havia encontrado nenhuma solução que resolvesse (ou talvez a solução não foi postada).

E espero que ajude quem passar ou estiver passando por esse mesmo problema.

Obrigado.

--
Você recebeu essa mensagem porque está inscrito no grupo "JasperReports / iReport Brasil" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para jasperreports-irepor...@googlegroups.com.
Para ver essa discussão na Web, acesse https://groups.google.com/d/msgid/jasperreports-ireport-brasil/6ce6e30a-0680-4291-98d8-283f1edba77b%40googlegroups.com.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages