Kotlin version 1.6.0 does not supporting Jacoco 0.8.7

743 views
Skip to first unread message

Ravikumar Valluri

unread,
Mar 9, 2022, 8:58:46 AM3/9/22
to JaCoCo and EclEmma Users
Hi All,
We have upgraded Kotlin version to 1.6.0 and there after Jacoco code coverage UT cases are failing in Jenkins. 

As per the document , Jacoco 0.8.7 does not support Kotlin 1.6.0 . Could you please some update me when we get latest version of Jacoco 0.8.8 to support Kotlin 1.6.0 version?

Thanks
Ravi

Marc Hoffmann

unread,
Mar 9, 2022, 9:00:17 AM3/9/22
to JaCoCo and EclEmma Users
Hi,

please provide details of the failure (full stack trace).

Thanks,
-marc

--
You received this message because you are subscribed to the Google Groups "JaCoCo and EclEmma Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jacoco+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/jacoco/b646fd2d-02c7-45c8-b3ac-ac6e39aa4cfdn%40googlegroups.com.

Ravikumar Valluri

unread,
Mar 9, 2022, 11:49:43 AM3/9/22
to JaCoCo and EclEmma Users

We still using Jacoco version (0.8.4) and latest Jacoco version 0.8.7  does not support Kotlin version 1.6.0.  I have gone through the JaCoCo release history and they are releasing new plugin 0.8.8 (beta) which supports Kotlin version 1.6.0

https://www.jacoco.org/jacoco/trunk/doc/changes.html

Thanks
Ravi

Evgeny Mandrikov

unread,
Mar 11, 2022, 6:56:54 PM3/11/22
to JaCoCo and EclEmma Users
The only as of today change in 0.8.8 related to Kotlin in https://www.jacoco.org/jacoco/trunk/doc/changes.html
is just about improvement of report in case of Kotlin "unsafe" cast operation,
and does not mean that you can not use JaCoCo 0.8.7 with Kotlin 1.6.0

There are many people who successfully use JaCoCo 0.8.7 with Kotlin 1.6.0 - see for example
If you absolutely need unreleased JaCoCo version, then please have a look at the very first FAQ entry

Fung Yam

unread,
Jan 19, 2023, 10:38:32 PM1/19/23
to JaCoCo and EclEmma Users

You need to specify jacoco.toolVersion in your gradle when upgrading from 0.8.5 -> 0.8.6.
It might cause your issue

Ahamed Mujeeb

unread,
Nov 22, 2023, 8:21:22 PM11/22/23
to JaCoCo and EclEmma Users
Hi..I'm facing an issue on excluding classes from coverage. I'm using Jacoco version 0.8.8. This is my original issue.
Thank You.


Regards,
Mujee
Reply all
Reply to author
Forward
0 new messages