building jacktrip from source--

15 views
Skip to first unread message

sid g

unread,
Mar 7, 2023, 4:23:19 PM3/7/23
to jacktrip-users
trying to build the latest stable jacktrip (1.7.1) from source following instructions
from the github document for ubuntu-debian, i got the following error message:

 release/src_gui_Failed_qml.cpp
/usr/lib/qt5/bin/qmlcachegen --resource=/home/sid/jacktrip/src/gui/qjacktrip.qrc -o release/src_gui_Meter_qml.cpp ../src/gui/Meter.qml
Error compiling qml file: ../src/gui/Meter.qml:6:14: error: Expected token `:'
make[1]: *** [Makefile.Release:530: release/src_gui_Meter_qml.cpp] Error 1
make[1]: Leaving directory '/home/sid/jacktrip/builddir'
make: *** [Makefile:42: release] Error 2

i was able to install  1.6.6 from the apt install jacktrip command but there was
no gui support or launch icon.  i found that if i ran the installation routine from /jacktrip
using sudo ./build install novs it worked properly and ran from an installed icon. the gui
also launches when i run jacktrip from a terminal without arguments.  i don't know where
i would be expected to see a 'guiMeter' anyway--am i missing out on something?

Marcin Pączkowski

unread,
Mar 7, 2023, 4:32:16 PM3/7/23
to jacktri...@googlegroups.com
I'm suspecting this might be due to Qt version requirements. JT (with Virtual Studio interface) requires Qt 5.15.x. If you build the "novs" version then it should work with older Qt (at least 5.12 I believe)
What version of Qt does your system provide? You can check that e.g. by running
qmake --version

Cheers,
Marcin

--
You received this message because you are subscribed to the Google Groups "jacktrip-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to jacktrip-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/jacktrip-users/b1c6af21-00c2-4be8-9742-60a821581c95n%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages