[UPD] X-000 3.0 è disponibile

7 visualizzazioni
Passa al primo messaggio da leggere

Taf®

da leggere,
19 ott 2008, 11:26:1619/10/08
a
C.D.O.
http://www.winpenpack.com/main/download.php?view.1035
PS: questa versione ci ha fatto un po' patire... perchè il programma
vuole delle dll presenti in C:\Winsows\system32 (msvcm90.dll,
msvcp90.dll, msvcr90.dll).

Ma dovremmo aver risolto...
per cortesia dateci una mano a testarlo su PC dove non sia stata
installata la versione ufficiale e dateci dei feedback.

e Buon X-OOO a tutti.

PPS: in futuro vedremo se è possibile integrarenel pack anche PDFImport

--
ByE bYe By Taf® - WinPenPack Team Member - FREE USB SW -
http://www.winpenpack.com
A: Because it disturbs the logical flow of the message.
Q: Why is top posting frowned upon?
R: Perche' disturba il flusso logico della lettura
D: Perche' "postare sopra" e' tanto fastidioso?


Tommy

da leggere,
19 ott 2008, 13:54:5219/10/08
a
ho notato alcuni piccoli problemi nel mantenimento delle impostazioni
personali.

fortunatamente sono risolvibili.

nella versione 2.4.1 erano salvate nella directory X-OpenOffice\User
\OpenOffice

mentre nella versione 3.0 la cartella ha un nome un po' diverso:

C:\Programmi\X-OpenOffice\User\OpenOffice.org 3

se uno quindi si limita a copiare ed incollare la directory X-
OpenOffice\User\ dalla 2.4.1 alla 3.0
rimane fregato perchè il nome della sub-sub-dir è diverso.

seconda cosa, pur copiando correttamente nel nuovo percorso le vecchie
impostazioni, all'apertura di OOo mi viene dato un messaggio di erore
I/O relativo ai files:

- dialog.xlc
- script.xlc

contenuti nella folder C:\Programmi\X-OpenOffice\User\OpenOffice.org
3\user\basic

dai test che ho fatto l'errore viene generato dai files presneti nelle
vecchie impostazioni della 2.4.1
se uno invece li sovrascirve con i files omonimi presenti nella
directory della 3.0 (che viene creata dopo la procedura di
registrizone al primo accesso al programma) questo messaggio di errore
non si ripresenta.

spero di essere stato chiaro.

P.S. ho WinXP Media Center Edition

Tommy

da leggere,
19 ott 2008, 16:38:1519/10/08
a
contrordine,

se uso i file dialog.xlc e script.xlc della 3.0 alcune macro non
funzionano.

le stesse macro funzionano normalmente se utilizzo i file della 2.4.1

come detto però alla'pertura del programma mi appare il seguente
messaggio di errore:

Errore nel caricare il BASIC del documento
file:///C:/Programmi/OpenOffice/Bin/OpenOffice.org%203/Basis/share/basic/Launcher/script.xlb/:
Errore generale.
Errore Genereale di I/O

e subito a seguire:

Errore nel caricare il BASIC del documento
file:///C:/Programmi/OpenOffice/Bin/OpenOffice.org%203/Basis/share/basic/Launcher/dialog.xlb/:
Errore generale.
Errore Genereale di I/O


che significa?

Tommy

da leggere,
20 ott 2008, 02:07:5820/10/08
a
aggiungo solo che al momento a parte quetsa schermata di errore che si
presneta solo al primo avvio, per il resto X-OOo 3.0 funziona
apparentemente senza problemi.

tutte le mie macro e le impostazioni precedentemente settate sulla X-
OOo 2.4.1 appaiono mantenute.

mi chiedo quindi se questo errore sia una sorta di "falso allarme" o
se effettivamente possa comportare dei rischi di malfunzionamento.
a questo punto passo la palla in mano a quelli di WinPenPack

grazie

VITRIOL

da leggere,
20 ott 2008, 02:17:5620/10/08
a
Tommy ha scritto:

> aggiungo solo che al momento a parte quetsa schermata di errore che si
> presneta solo al primo avvio, per il resto X-OOo 3.0 funziona
> apparentemente senza problemi.

Prova semplicemente a cancellare i due file incriminati dopo averne
fatto un backup.

--
news:it-alt.comp.software.openoffice : Il newsgroup dedicato a
OpenOffice.org, la suite open source di applicazioni per ufficio.
Scarica "OpenOffice.org 3, I suppose", molto di più di semplici FAQ!
http://it.openoffice.org/doc/manuali/

Taf®

da leggere,
20 ott 2008, 10:32:3020/10/08
a
19/10/2008 .....Tommy ha scritto/wrote/a écrit :
> ho notato alcuni piccoli problemi nel mantenimento delle impostazioni
> personali.
>
> fortunatamente sono risolvibili.
>
> nella versione 2.4.1 erano salvate nella directory X-OpenOffice\User
> \OpenOffice
>
> mentre nella versione 3.0 la cartella ha un nome un po' diverso:
>
> C:\Programmi\X-OpenOffice\User\OpenOffice.org 3
>
> se uno quindi si limita a copiare ed incollare la directory X-
> OpenOffice\User\ dalla 2.4.1 alla 3.0
> rimane fregato perchè il nome della sub-sub-dir è diverso.

è una modifica voluta:
siccome la 3.0 non supporta più win98SE, verrà mantenuta in DL anche la
vecchia 2.4.1!
tenendo i profili utente in due diverse cartelle sarà possibile far
coesistere le 2 versioni portabilizzate su una chiavetta per
utilizzarle alternativamente su vecchie e/o nuove macchine ospiti.
Senza creare conflitti di profilo.


>
> seconda cosa, pur copiando correttamente nel nuovo percorso le vecchie
> impostazioni, all'apertura di OOo mi viene dato un messaggio di erore
> I/O relativo ai files:
>
> - dialog.xlc
> - script.xlc
>
> contenuti nella folder C:\Programmi\X-OpenOffice\User\OpenOffice.org
> 3\user\basic
>
> dai test che ho fatto l'errore viene generato dai files presneti nelle
> vecchie impostazioni della 2.4.1
> se uno invece li sovrascirve con i files omonimi presenti nella
> directory della 3.0 (che viene creata dopo la procedura di
> registrizone al primo accesso al programma) questo messaggio di errore
> non si ripresenta.
>
> spero di essere stato chiaro.
>
> P.S. ho WinXP Media Center Edition

direi che anche questo "pseudoerrore" sia da ascriversi alla volontà di
tenere profili separati per le due versioni.

Taf®

da leggere,
20 ott 2008, 10:34:2520/10/08
a
19/10/2008 .....Tommy ha scritto/wrote/a écrit :

??? ...vedremo di approfondire...

Ma, come già detto, la volontà di separare i dati utente tra 2.4.1 e
3.0 è una necessità per far conviverele due versioni sulla medesima
chiavetta.

Tommy

da leggere,
20 ott 2008, 13:14:1220/10/08
a
@VITRIOL
cancellando i files ricevo ulteriori messaggi di errore all'apertura
di OOo.

@ Taf®
tutto ok per la questione della subsubdir. io uso XP percui mi va
benissimo trasferire il tutto nella nuova directory.

per quanto riguarda i files dialog.xlc e script.xlc la questione è la
seguente:
mantenendo i files provenienti dalla 2.4.1 si ricevono quei messaggi
di errore all'apertura e poi tutto fila liscio, le impstazioni sono
conservate e le macro funzionano.
utilizzando invece i files creati alla prima inizializzazione della
3.0 e facendoli convivere con i restanti user-files della 2.4.1 invece
non compaiono messaggi di errore ma certe macro non funzionano. in
particolare i malfunzionamenti sono relativi a queste macro:

http://www.darwinwars.com/lunatic/bugs/oo_macros.html
http://www.darwinwars.com/lunatic/bugs/installer_acb.sxw

quando attivo una di queste macro ricev o il sgeuente messaggio di
errore

Errore dello schema di scripting durante l'esecuzione dello script
Basic vnd.sun.star.script:abcTools.WordCount?
language=Basic&location=application.

Messaggio: The following Basic script could not be found:
library: 'abcTools'
module: 'WordCount'
method: WordCount'
location ' application'

ovviamente non so che cosa significhi, lascio la parola a chi è più
esperto di me

Taf®

da leggere,
21 ott 2008, 06:20:3421/10/08
a

Ciao Tommy,
per condividere questa tua esperienza "approfondita" di X-OOO3 potrei
riportare queste tue info nel forum di winPenPack.
Ma sarebbe meglio se fossi tu stesso ad aprire un topic.
Ti scoccia?? ;-) ...grazie per la comprensione!
ti linko qui il punto appropriato in cui postare:

di nuovo grazie per il tuo aiuto a risolvere queste problematiche.
http://www.winpenpack.com/main/e107_plugins/forum/forum_viewforum.php?3
PS: l'eventuale soluzione la possiamo poi riportare anche su questo
thread.

Tommy

da leggere,
21 ott 2008, 09:19:2221/10/08
a
sono di frettissima perchè sono in partenza e torno domenica

ti rispondo brevemente: vedrò di iscrivermi al mio ritorno al tuo
forum. nel frattempo se riesci aprilo tu il topic con copia e incolla
dei miei messaggi

mi è venuta un'idea: bisognerebbe provare ad installare ex novo gli
abc Tools su un X-OOo 3.0 vergine e vedere se il rpobelma si
rirpopone.

non vorrei che avevndoli isntallati su una 2.4.1 ci siano alcune
incompatibilità

Rispondi a tutti
Rispondi all'autore
Inoltra
0 nuovi messaggi