ipaddr-2.1.10 on pypi and ipaddr-2.1.11 released

61 views
Skip to first unread message

Peter Moody

unread,
Jan 31, 2014, 4:58:29 PM1/31/14
to ipaddr...@googlegroups.com
Hey folks,

so I finally got around to uploading ipaddr-2.1.10 to pypi.

https://pypi.python.org/pypi/ipaddr/2.1.10

I've also gone ahead and created a release for the changes from the last two (!) years. code.google.com has, ahem, helpfully changed how I can make downloads available, so the new link is

https://drive.google.com/folderview?id=0Bwh63zyus-UlZ1dxQ08zczVRbXc&usp=sharing.

Don't worry, it's linked from the project page.

Cheers,
peter

Doug Hellmann

unread,
Feb 7, 2014, 12:27:46 PM2/7/14
to ipaddr...@googlegroups.com
As reported https://code.google.com/p/ipaddr-py/issues/detail?id=96 Google Drive isn't allowing any more downloads of the packages stored there because the file has already been downloaded too many times.

Could you upload a package to PyPI?

Thanks,
Doug

Claudio Freire

unread,
Feb 7, 2014, 12:56:46 PM2/7/14
to Doug Hellmann, ipaddr-py-dev
Given that restriction, I submit to your attention that moving file
releases from code.google.com to google drive was a shitty move. Tell
google to remove the restriction or re-support downloads directly in
code.google.com.

Peter Moody

unread,
Feb 7, 2014, 1:05:41 PM2/7/14
to Doug Hellmann, ipaddr...@googlegroups.com
Well that's annoying. I've emailed the code.google.com folks to ask what I can do.

> Could you upload a package to PyPI?

I'm trying but pypi isn't playing nicely. Unfortunately I think I might've deleted the 2.1.10 release while trying to update to 2.1.11 :-/.

> Thanks,
> Doug

Peter Moody

unread,
Feb 7, 2014, 1:11:18 PM2/7/14
to Doug Hellmann, ipaddr...@googlegroups.com
Alright, 2.1.11 is now on pypi. phew. Thanks for bearing with me here folks.

>> Thanks,
>> Doug

Doug Hellmann

unread,
Feb 7, 2014, 2:44:46 PM2/7/14
to Peter Moody, ipaddr...@googlegroups.com
I confirmed that I can install it with pip.

Thanks for a speedy response, Peter!

Doug

Peter Moody

unread,
Feb 7, 2014, 2:52:52 PM2/7/14
to Doug Hellmann, ipaddr...@googlegroups.com

On Fri, Feb 07 2014 at 11:44, Doug Hellmann wrote:
> I confirmed that I can install it with pip.
>
> Thanks for a speedy response, Peter!

Great, thanks! I'm still waiting to hear back from the drive folks. If I don't get a satisfactory response I'll just default to putting releases on PyPi to avoid this mess in the future.


Doug Hellmann

unread,
Feb 7, 2014, 3:12:10 PM2/7/14
to Peter Moody, ipaddr...@googlegroups.com
That's probably what you want to do anyway. The newer versions of pip refuse to install anything that isn't uploaded to PyPI unless you pass extra arguments to indicate each package that can be downloaded from somewhere else. That makes using ipaddr as a dependency difficult.

Doug

Dolph Mathews

unread,
Feb 7, 2014, 6:27:13 PM2/7/14
to ipaddr...@googlegroups.com, Doug Hellmann
Thank you for the quick turnaround!

Reply all
Reply to author
Forward
0 new messages