After updating to inno 6.1.2 wine on mac says "windows version not supported"

73 views
Skip to first unread message

Jean Cremers

unread,
Feb 5, 2021, 4:52:12 PMFeb 5
to innosetup
The guy is using winebottler from https://winebottler.kronenberg.org 
He says the previous installer did not complain, what can this be?

Eivind Bakkestuen

unread,
Feb 5, 2021, 8:31:22 PMFeb 5
to inno...@googlegroups.com
Could you tell us which Inno version the previous installer used?

Likely some windows API function used in the latest version is not supported in the wine version being used. Ask the guy if he can get more detailed logs (which he can then supply to winebottler...).

On Sat, Feb 6, 2021 at 7:52 AM Jean Cremers <jeanc...@gmail.com> wrote:
The guy is using winebottler from https://winebottler.kronenberg.org 
He says the previous installer did not complain, what can this be?

--
You received this message because you are subscribed to the Google Groups "innosetup" group.
To unsubscribe from this group and stop receiving emails from it, send an email to innosetup+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/innosetup/68205474-75f7-41c8-9d8c-821635ad2b17n%40googlegroups.com.

Jean Cremers

unread,
Feb 6, 2021, 3:47:05 AMFeb 6
to innosetup
Dunno what previous version that was, sorry. Isn't this something that can be fixed with MinVersion?

Eivind Bakkestuen

unread,
Feb 6, 2021, 4:45:40 AMFeb 6
to inno...@googlegroups.com
Depends. Actually, is the error message in the subject line from Wine itself, or thrown up from the installer? If installer is run with /LOG, is anything produced?

jeremy

unread,
Feb 6, 2021, 7:52:03 AMFeb 6
to innosetup
hello everyone and thanks for the help. I am the person in question. to sum up 
I am under mac sierra. 
To make the software work I apparently installed: 
- XQuartz-2.7.11 
-WineBottlerCombo_1.6.1 
- winehq-stable-4.0.3 (maybe but dont think so because I don't know how to install something without installing a launcher app) 
Everything was ok before the last update about which i got an error message below
I updated with WineBottler 1.8.6 Stable which doesn't change anything
you can tell me how to proceed if I can test something. Be patient I'm not very good at computer langage and not as good in english.
thnks
Jeremy

wine-error.jpg

Eivind Bakkestuen

unread,
Feb 6, 2021, 7:46:32 PMFeb 6
to inno...@googlegroups.com
OP, If you want to get your latest version going under wine[bottler], it's likely that reverting to your previously used Inno version would take care of it and be the easiest way forward. In the build system I maintain, I build certain versions with Inno 5.x because some customers demand Windows XP support. You can have both versions installed simultaneously.

Otherwise, you're up for investigating, playing around with wine[bottler] versions and settings, Inno's MinVersion, etc etc.

Personally, I don't have a Mac, sorry. I have to bow out here.


--
You received this message because you are subscribed to the Google Groups "innosetup" group.
To unsubscribe from this group and stop receiving emails from it, send an email to innosetup+...@googlegroups.com.

Jean Cremers

unread,
Feb 7, 2021, 5:54:57 AMFeb 7
to innosetup

Thank you. The latest 5.x version didn't work, i tried the earliest 5.x which is 5.5.8,  Jeremy says this one works. 
Which ones do you use?
Reply all
Reply to author
Forward
0 new messages