Pull request 933 in include-what-you-use: Adjust to use new UsingDecl APIs

0 views
Skip to first unread message

notifi...@include-what-you-use.org

unread,
Jul 5, 2021, 1:54:32 PMJul 5
to include-wh...@googlegroups.com
New pull request 933 by kimgr: Adjust to use new UsingDecl APIs
https://github.com/include-what-you-use/include-what-you-use/pull/933

Clang extracted some shared code into BaseUsingDecl and renamed
UsingShadowDecl::getUsingDecl -> getIntroducer in ddda05add527:
https://github.com/llvm/llvm-project/commit/ddda05add527f7f92a71f387b927f237334f46d9

Add some downcasting to preserve the current behavior and ignore the new C++20
UsingEnumDecls for now.

Reply all
Reply to author
Forward
0 new messages