Addressing (in code) users "root" and "Guest" using named contants
14 views
Skip to first unread message
Alexander Obuhovich
unread,
May 18, 2010, 8:30:19 AM5/18/10
Reply to author
Sign in to reply to author
Forward
Sign in to forward
Delete
You do not have permission to delete messages in this group
Copy link
Report message
Show original message
Either email addresses are anonymous for this group or you need the view member email addresses permission to view the original message
to In-Portal Development
System users "root" (id = -1) and "Guest" (id = -2) are using in In-Portal since it's first version. Despite their popularity we always use their IDs in code and not thinking about creating named constants.
I say enough to mystic numbers and propose to create constants:
USER_ROOT - for "-1" value
USER_GUEST - for "-2" value
I've already did that and replaced all places, where I've found that magic numbers with proposed constants.