Incorrectly included templates via <inp2:m_ModuleInclude tag

5 views
Skip to first unread message

Alexander Obuhovich

unread,
Jun 4, 2012, 7:12:24 AM6/4/12
to In-Portal Bugs
In-Portal has 2 tags, that allow to use same template multiple times on other different templates:
  • <inp2:m_Include - includes 1 given template
  • <inp2:m_ModuleInclude - includes given template from each module
There is a problem with m_ModuleInclude tag in Admin Console, where he uses "core/" prefix to include templates from core module (see attached image). This works of course (otherwise whole "Structure & Data" section would be dead), but when you need to replace template, that is included (e.g. "catalog_tab" from core module), then you need to write "core/" before replaced template name.

What I've described might not be a bug, but because of "Sections" tab in "Structure & Data" page is loaded via ajax and is accessing "catalog_tab" (and not "core/catalog_tab", that was replaced) resulting page uses original non-replaced template.


--
Best Regards,

http://www.in-portal.com
http://www.alex-time.com
inportal_module_include_admin.png

Dmitry A.

unread,
Jun 9, 2012, 12:14:59 PM6/9/12
to in-port...@googlegroups.com
Hi Alex,


So what you are proposing to do here?


DA

Alexander Obuhovich

unread,
Jun 9, 2012, 1:10:30 PM6/9/12
to in-port...@googlegroups.com
Inside m_ModuleInclude tag when we have "core" or "In-Portal" module template being included strip it's module path (core/) from the path.

This way template replacement will work.




DA

--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To view this discussion on the web visit https://groups.google.com/d/msg/in-portal-bugs/-/1dRpDqGVhs8J.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.

Dmitry A.

unread,
Oct 19, 2012, 12:09:20 AM10/19/12
to in-port...@googlegroups.com
Is this still active issue and requires some sort of action?

DA

Alexander Obuhovich

unread,
Nov 5, 2012, 11:44:06 AM11/5/12
to Bugs In-Portal
Yes, subject is still in the air.



To view this discussion on the web visit https://groups.google.com/d/msg/in-portal-bugs/-/Vav1rf9sPygJ.

To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.

Alexander Obuhovich

unread,
Nov 7, 2012, 7:08:51 AM11/7/12
to Bugs In-Portal
Here is the patch.

Ready for testing.
moduleinclude_and_core_fix.patch
Reply all
Reply to author
Forward
0 new messages