Expire Admin Session after Installation (5.0.2-B2)

1 view
Skip to first unread message

Dmitry A.

unread,
Dec 30, 2009, 5:01:37 PM12/30/09
to In-Portal Bugs
Hey guys,

This has been noticed by me and some other people.

Currently there is an issue when user is getting logged in into the
Admin straight away as soon as they completed the installation and
some (sometimes all) of the Language labels are shown as not
translated when they actually are.

This happens only after the installation and goes away if you re-
logout.

I propose to auto-Expire/Delete that session after the installation.

Task has been filed for this:

511: Expire Admin Session after Installation

http://tracker.in-portal.org/view.php?id=511

Cheers!

DA.

Alexander Obuhovich

unread,
Dec 30, 2009, 5:07:01 PM12/30/09
to in-port...@googlegroups.com
I just figured out what it was. Session is created before language pack is imported and 0 is stored as current admin language in it. We need to simply perform $this->Application->Session->SetField('Language', 1); after performing initial language pack import. Also we need to store special variable in persistent session (for root user, this is user, who is initially logged in into admin) to indicate, that 1 language should be used next time root performs login to administrative console.


--

You received this message because you are subscribed to the Google Groups "In-Portal Bugs" group.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.





--
Best Regards,

http://www.in-portal.org
http://www.alex-time.com

Dmitry A.

unread,
Dec 30, 2009, 5:14:00 PM12/30/09
to In-Portal Bugs
I understand, but still see NO purpose NOT to require login after the
install is completed, do you?

DA.

> > in-portal-bug...@googlegroups.com<in-portal-bugs%2Bunsubscribe@go­oglegroups.com>

Alexander Obuhovich

unread,
Dec 30, 2009, 5:16:49 PM12/30/09
to in-port...@googlegroups.com
Why administrator should be forced to login after installation, when there is only one user in system - root?

To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.


Dmitry A.

unread,
Dec 30, 2009, 6:40:37 PM12/30/09
to In-Portal Bugs
Yes, you have a valid point, but still imagine that you don't want to
Login straight away. In some cases you just want to complete install
for someone else and that's it.

Plus this would give Admin to practice his "root" password and make
sure he remembers it.

I vote for deleting Root session after the initial install so he is
forced to Login.

Cheers!

DA.

Alexander Obuhovich

unread,
Dec 31, 2009, 11:55:08 AM12/31/09
to in-port...@googlegroups.com
I propose we divide this issue into two tasks:
1. language missing after installation
2. auto-logout admin user after installation

1st task could be implemented, but 2nd task should be discussed, because 2 opinions are not enough to decide what to do with it.

To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.


Dmitry A.

unread,
Jan 1, 2010, 2:53:17 PM1/1/10
to In-Portal Bugs
Sounds like a plan:

1st task (bug)
514: Language missing after installation
http://tracker.in-portal.org/view.php?id=514

2nd task (feature request):
511: Auto-Logout Admin Session after Installation
http://tracker.in-portal.org/view.php?id=511

I think we should fix the bug in 5.0.2

Cheers!

DA

On Dec 31 2009, 10:55 am, Alexander Obuhovich <aik.b...@gmail.com>
wrote:

> > > > > > in-portal-bug...@googlegroups.com<in-portal-bugs%2Bunsu...@googlegroups.com>


> > <in-portal-bugs%2Bunsubscribe@go­oglegroups.com>
> > > > <in-portal-bugs%2Bunsubscribe@go­oglegroups.com>
> > > > > > .
> > > > > > For more options, visit this group at
> > > > > >http://groups.google.com/group/in-portal-bugs?hl=en.
>
> > > > > --
> > > > > Best Regards,
>
> > > > >http://www.in-portal.orghttp://www.alex-time.com
>
> > > > --
>
> > > > You received this message because you are subscribed to the Google
> > Groups
> > > > "In-Portal Bugs" group.
> > > > To post to this group, send email to in-port...@googlegroups.com.
> > > > To unsubscribe from this group, send email to

> > > > in-portal-bug...@googlegroups.com<in-portal-bugs%2Bunsu...@googlegroups.com>


> > <in-portal-bugs%2Bunsubscribe@go­oglegroups.com>
> > > > .
> > > > For more options, visit this group at
> > > >http://groups.google.com/group/in-portal-bugs?hl=en.
>
> > > --
> > > Best Regards,
>
> > >http://www.in-portal.orghttp://www.alex-time.com
>
> > --
>
> > You received this message because you are subscribed to the Google Groups
> > "In-Portal Bugs" group.
> > To post to this group, send email to in-port...@googlegroups.com.
> > To unsubscribe from this group, send email to

> > in-portal-bug...@googlegroups.com<in-portal-bugs%2Bunsu...@googlegroups.com>

Reply all
Reply to author
Forward
0 new messages