Incorrect SQL queries with duplicate JOIN clauses

5 views
Skip to first unread message

Erik Snarski

unread,
Jan 17, 2013, 6:24:26 AM1/17/13
to in-port...@googlegroups.com
Screenshot with SQL error attached. I do knot now how repeat this error, but I had it several times with different tables.
inportal_sql_bug.png

Alexander Obuhovich

unread,
Jan 17, 2013, 8:32:22 AM1/17/13
to Bugs In-Portal
This is a duplicate of https://groups.google.com/d/topic/in-portal-bugs/tfG6XtZpbK0/discussion .

Test case:
  1. add LEFT JOIN to ListSQLs/ItemSQLs setting in unit config from OnAfterConfigRead event
  2. empty cache from one place (e.g. by calling "do_update" script)
  3. open page where modified unit is used (cache is now built and OnAfterConfigRead is called 2 times)
Erik, if you can propose any solution to that, then please post in discussion I've indicated above.


On Thu, Jan 17, 2013 at 1:24 PM, Erik Snarski <sn...@jamajo.lv> wrote:
Screenshot with SQL error attached. I do knot now how repeat this error, but I had it several times with different tables.

--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To view this discussion on the web visit https://groups.google.com/d/msg/in-portal-bugs/-/dv-4iDCyY-MJ.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.



--
Best Regards,

http://www.in-portal.com
http://www.alex-time.com
Reply all
Reply to author
Forward
0 new messages