URL parts' escape in Upload Formatter

2 views
Skip to first unread message

S.G.

unread,
Jan 26, 2010, 2:55:43 AM1/26/10
to In-Portal Bugs Team
Try to upload file with symbols such as "#" or "+" in file name via
our standard SWF uploader. You'll see that when full url is built,
it's incorrect because file name is not urlencoded. Also this is
applicable to folder names in URL - for example, in URL
http://www.sitename.com/system/part1/part2/filename.ext part1, part2 &
filename.ext (& system?) need to be urlencoded. Another case is non-
formatter URL building to uploaded files, I found one in OnViewFile
event.

Dmitry A.

unread,
Jan 26, 2010, 10:21:49 AM1/26/10
to In-Portal Bugs Team
Hi Sergey,


Yes, this seems to be the case - thanks for pointing out.

Did you have a chance to patch this in your installation yet?


Thanks.

DA.

On Jan 26, 1:55 am, "S.G." <sergb...@gmail.com> wrote:
> Try to upload file with symbols such as "#" or "+" in file name via
> our standard SWF uploader. You'll see that when full url is built,
> it's incorrect because file name is not urlencoded. Also this is

> applicable to folder names in URL - for example, in URLhttp://www.sitename.com/system/part1/part2/filename.extpart1, part2 &

Alexander Obuhovich

unread,
Mar 27, 2010, 6:29:01 PM3/27/10
to in-port...@googlegroups.com
We are just lucky, since not much users have uploaded files with such characters in it's name. Here is the task: http://tracker.in-portal.org/view.php?id=662

--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.




--
Best Regards,

http://www.in-portal.com
http://www.alex-time.com
Reply all
Reply to author
Forward
0 new messages