Minor Issue with opening Import Data section in Admin

1 view
Skip to first unread message

Dmitry Andrejev

unread,
May 14, 2010, 6:57:57 PM5/14/10
to In-Portal Bugs Team
Hi guys,


I think a new minor Interface bug found starting 5.0.1 release:

I am Getting page opened in the Left Menu (instead of main page) when
clicking on Admin->Tools->Import Data section while using "Same
Window" pop-up mode (enabled via Admin->Configuration->Advanced:
Editing Window Style).

Also, tested in 5.1.0 - same problem.


New task filed:

731: Issue with opening Import Data section in Admin

http://tracker.in-portal.org/view.php?id=731


DA.

--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.

export_issue.png

Dmitry Andrejev

unread,
Dec 6, 2010, 12:20:38 PM12/6/10
to In-Portal Bugs Team
Hi Alex,


I am looking at this task and have a question for you.

Currently we use:

 'onclick' => 'direct_edit(\'adm\', this.href);',


in the following context:


'in-portal:main_import' => Array (
'parent' => 'in-portal:tools',
'icon' => 'import_data',
'label' => 'la_tab_ImportData',
'url' => Array ('t' => 'tools/import1'),
'onclick' => 'direct_edit(\'adm\', this.href);',
'permissions' => Array ('view'),
'priority' => 3,
'type' => stTREE,
),

 
Looks like the problem is that in direct_edit JS method we are NOT considering that URL needs to to be opened in a Main frame and not the current one.


I think we can pass here the Target Frame name?

function direct_edit($prefix_special, $url) {
if (use_popups($prefix_special, '')) {
openSelector($prefix_special, $url);
}
else {
redirect($url);
}

return false;
}



Thanks





On Fri, May 14, 2010 at 5:57 PM, Dmitry Andrejev <dand...@gmail.com> wrote:
Hi guys,


I think a new minor Interface bug found starting 5.0.1 release:

I am Getting page opened in the Left Menu (instead of main page) when
clicking on Admin->Tools->Import Data section while using "Same
Window" pop-up mode (enabled via Admin->Configuration->Advanced:
Editing Window Style).

Also, tested in 5.1.0 - same problem.


New task filed:

731: Issue with opening Import Data section in Admin

http://tracker.in-portal.org/view.php?id=731


DA.



--


Best regards,

Dmitry A.

Dmitry Andrejev

unread,
Dec 6, 2010, 2:22:02 PM12/6/10
to In-Portal Bugs Team
Here is a patch for this task. Please review.


DA
Issue-with-opening-Import-Data-section-in-Admin.patch

Alexander Obuhovich

unread,
Dec 7, 2010, 9:30:41 AM12/7/10
to in-port...@googlegroups.com
No need to change "direct_edit" function, since we usually don't open links in places other, then main frame.

--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.
Reply all
Reply to author
Forward
0 new messages