Not Used Variable. Configuration->Users->General

11 views
Skip to first unread message

Vjacheslav Vishnjakov

unread,
Jan 28, 2011, 10:21:46 AM1/28/11
to in-port...@googlegroups.com
Minimum user name length
[10.03] Min_UserName

Var. from config Not Used. Validate for Login length not working. 


Dmitry A.

unread,
Jan 28, 2011, 10:41:37 AM1/28/11
to in-port...@googlegroups.com
Hi all,


Yes, I can confirm that Min_UserName setting is not checked anywhere in the User Event Handler (tested on In-Portal 5.1.2-B1).

I guess we should create a task for this (should be simple).


By the way, Slava if you already have a fix for it - you are welcome to attach here (in the groups) in the way of Patch file.


Cheers!


DA

Vjacheslav

unread,
Jan 29, 2011, 11:34:03 AM1/29/11
to In-Portal Bugs Team
I'm Sorry.
I'm not ready to make corrections.
I have a different style of programming. My patch will not be in the
style of in-portal.
I need time to sort out project struktre .... :)

SL.

Alexander Obuhovich

unread,
Jan 29, 2011, 11:38:29 AM1/29/11
to in-port...@googlegroups.com
Here is guide for new community members about patching:
  1. make necessary changes to fix the bug on your project
  2. copy (via any compare tool, like CompareIt! or WinMerge) changes you've made to clean In-Portal checked out version
  3. click "TortoiseSVN -> Create Patch ..." option (I suppose you've got TortoiseSVN installed)
In meanwhile you can just attach all changed files here and please write In-Portal version files comes from too.


I'll create a patch this time.



--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.




--
Best Regards,

http://www.in-portal.com
http://www.alex-time.com

Vjacheslav

unread,
Jan 29, 2011, 11:42:42 AM1/29/11
to In-Portal Bugs Team

I propose the possibility to check the user name with the appropriate
character Latin alphabet (optional)

Alexander Obuhovich

unread,
Jan 29, 2011, 11:54:35 AM1/29/11
to in-port...@googlegroups.com
We actually already have a big discussion https://groups.google.com/d/topic/in-portal-dev/_zXDBTcrRiw/discussion about how exactly is the best way to do it, including upgrade of existing installation, where some of usernames will not be validated by default.


On Sat, Jan 29, 2011 at 6:42 PM, Vjacheslav <vjach...@gmail.com> wrote:

I propose the possibility to check the user name with the appropriate
character Latin alphabet (optional)
--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.

Dmitry A.

unread,
Jan 29, 2011, 3:21:42 PM1/29/11
to in-port...@googlegroups.com
Hi guys,


New task has been file for described here bug:


984: User Login field is not checked for minimum characters



Patch (once available) should be attached to the discussion and the task.


DA

Alexander Obuhovich

unread,
Jan 29, 2011, 3:23:59 PM1/29/11
to in-port...@googlegroups.com
Maybe we should check for all configuration variables at least being used, since it's the second case of non-used configuration variable encounter since 5.x version.


--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.

Dmitry A.

unread,
Jan 29, 2011, 3:40:04 PM1/29/11
to in-port...@googlegroups.com
Yes, I think it's a clever idea!

I guess we need a Task for 5.1.3 then.

Alex, would you please create one.


DA

Alexander Obuhovich

unread,
Feb 5, 2011, 9:02:28 AM2/5/11
to in-port...@googlegroups.com
Here is the task for that too: http://tracker.in-portal.org/view.php?id=990



DA

--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.
Reply all
Reply to author
Forward
0 new messages