Bugs from In-Portal 5.2.1-B1 testing

7 views
Skip to first unread message

Alexander Obuhovich

unread,
Nov 9, 2012, 11:20:29 AM11/9/12
to Bugs In-Portal
I've found following bugs during testing In-Portal 5.2.1-B1 install one a new project:
  1. When adding administrator in "Users Management -> Administrators" section window title shows "Add User" instead of "Add Administrator". Suspect that "User" word is all over that section phrases instead of "Administrator" word.
  2. After clean install category permission cache missing that results in all theme-related sections missing from "Structure & Data" section. That's why I need to use "Rebuild Section Cache" menu in that section to start working with "Structure & Data" section.
  3. Section "System Log", that was added under "System Logs" is visible in "simple" interface preset, but we have a rule, that all new sections are hidden by "simple" interface preset by default.

--
Best Regards,

http://www.in-portal.com
http://www.alex-time.com

Dmitry A.

unread,
Nov 12, 2012, 12:38:38 AM11/12/12
to in-port...@googlegroups.com
Hi Alex,


Thanks for reporting!

Below are new 3 tasks for In-Portal 5.2.1:






PS. I think it's okay that all 3 reference to this discussion (all items are minor ones and result of 5.2.1-B1)


DA

Dmitry Andrejev

unread,
Dec 2, 2012, 11:04:01 PM12/2/12
to in-port...@googlegroups.com
Hi Alex, 


Let's talk about issue 1439: Missing "Category Permission Cache" after Installation  for a minute

"After clean install category permission cache missing that results in all theme-related sections missing from "Structure & Data" section. That's why I need to use "Rebuild Section Cache" menu in that section to start working with "Structure & Data" section."

As you indicated below there are Pros and Cons:

Pros: theme file rebuild on each deploy isn't slow on large projects (with lots of categories)
Cons: no automatic category permission rebuild on theme rebuild


There seems to be an issue however when we have Simple preset with no option to manually rebuild the Categories Cache at all and need to go back and forth with Presets after the installation. I think we should come up with some clever way of detecting whether do Manual or Force auto-rebuild. Can this depend on Total number of categories we have in Catalog? Sorry if I missed anything in between.


DA


Phil

unread,
Dec 3, 2012, 2:49:49 AM12/3/12
to in-port...@googlegroups.com
Hi guys,

we talked about this rebuild speed problem already, let me post the link here, we had some ideas: https://groups.google.com/d/topic/in-portal-dev/IIg-w-a0vgU/discussion

p


Envoyé avec Sparrow

--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To view this discussion on the web visit https://groups.google.com/d/msg/in-portal-bugs/-/cclt7Hr966cJ.
To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.

Alexander Obuhovich

unread,
Dec 3, 2012, 3:13:30 AM12/3/12
to Bugs In-Portal
I've found how to solve that looking at AdminTagProcessor::CheckPermCache method, which decides whatever we need to rebuild category permission cache when catalog is visited.

We simply need to put ForcePermCacheUpdate mark into system cache (setDBCache method) and then once "Structure & Data" section will be visited + this mark present automatic cache rebuild (with progress bar) will start.

This way if we can do silent cache rebuild we do it, but if we can't we just put a mark to indicate that it needs to be done.




--
You received this message because you are subscribed to the Google Groups "In-Portal Bugs Team" group.
To view this discussion on the web visit https://groups.google.com/d/msg/in-portal-bugs/-/cclt7Hr966cJ.

To post to this group, send email to in-port...@googlegroups.com.
To unsubscribe from this group, send email to in-portal-bug...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/in-portal-bugs?hl=en.

Alexander Obuhovich

unread,
Dec 3, 2012, 3:16:13 AM12/3/12
to Bugs In-Portal
Thanks, Phil. I've added http://tracker.in-portal.org/view.php?id=1318 task from discussion link you've posted as related to task from current discussion.

Phil

unread,
Dec 3, 2012, 3:36:20 AM12/3/12
to in-port...@googlegroups.com
silence cache rebuild seems a must-have anyway, wether catalog is huge or not.


Envoyé avec Sparrow

Alexander Obuhovich

unread,
Dec 3, 2012, 8:56:57 AM12/3/12
to Bugs In-Portal
As I said before: silent cache rebuild + large catalog = out of memory error. And because it's happening in background nobody will be able to do anything about it (while in simple interface preset).

Phil

unread,
Dec 3, 2012, 10:16:23 AM12/3/12
to in-port...@googlegroups.com
so may cache rebuild need an upgrade too?


Envoyé avec Sparrow

Alexander Obuhovich

unread,
Dec 4, 2012, 3:50:35 AM12/4/12
to Bugs In-Portal
so may cache rebuild need an upgrade too?

This will be done automatically (cache rebuild mark set, when theme files will be added).


Here is the patch (made by Erik) for http://tracker.in-portal.org/view.php?id=1438 task.
add_edit_administrator_title_1438.patch

Alexander Obuhovich

unread,
Dec 4, 2012, 4:14:20 AM12/4/12
to Bugs In-Portal
Here is the patch for http://tracker.in-portal.org/view.php?id=1440 task.
hide_system_log_v2.patch

Alexander Obuhovich

unread,
Dec 4, 2012, 4:51:47 AM12/4/12
to Bugs In-Portal
Here is the patch for http://tracker.in-portal.org/view.php?id=1441 task.
installation_constants_modules_v2.patch
Reply all
Reply to author
Forward
0 new messages