SSL iFolder Enterprise.

56 views
Skip to first unread message

ntrcessor

unread,
May 22, 2011, 11:51:59 PM5/22/11
to iFolder-Ubuntu-Debian-Android-dev

I can enable SSL on the server, and the web admin works, except for on
the "system" tab, I get the following error:


Server Version: 1.8.3.0
HostName: ifoldere
MachineName: ifoldere
OS Version: Unix 2.6.32.21
CLR Version: 2.0.50727.1433


Exception detail:

Exception type: Exception

Unable to connect to master serverSystem.Net.WebException: Error
writing request: The authentication or decryption has failed.
at System.Net.WebConnectionStream.WriteHeaders () [0x00000]
at System.Net.WebConnectionStream.SetHeaders (System.Byte[] buffer)
[0x00000]
at (wrapper remoting-invoke-with-check)
System.Net.WebConnectionStream:SetHeaders (byte[])
at System.Net.HttpWebRequest.SendRequestHeaders (Boolean
propagate_error) [0x00000]

at Novell.iFolderWeb.Admin.SystemInfo.ConnectToMaster () [0x00000]
at Novell.iFolderWeb.Admin.SystemInfo.Page_PreRender (System.Object
source, System.EventArgs e) [0x00000]
at System.Web.UI.Control.OnPreRender (System.EventArgs e) [0x00000]
at System.Web.UI.Control.PreRenderRecursiveInternal () [0x00000]
at System.Web.UI.Page.ProcessLoadComplete () [0x00000]
at System.Web.UI.Page.InternalProcessRequest () [0x00000]
at System.Web.UI.Page.ProcessRequest (System.Web.HttpContext
context) [0x00000]


I see from googling that this error shows up on OTHER mono projects
compiled with SSL support, and seems to be a bug w/ Mono.

I used the following on Lucid Lynx (Ubuntu 10.04) to install the
server:
http://ubuntuforums.org/showthread.php?t=1699207

If my urls are http:// I don't get errors, but if I try to switch to
SSL urls, then I get the above error in the /admin section under the
"System" tab. Other tabs seem to work fine. Haven't tried using web
login yet, or a client on this setup. (Used a version that didn't
support SSL or using encrypted drive space earlier, which doesn't meet
our clients needs.)
Reply all
Reply to author
Forward
0 new messages