Installation errors

43 views
Skip to first unread message

Wiktoria Rajewicz

unread,
May 31, 2023, 9:27:43 AM5/31/23
to idtracker.ai users group
Hi everyone! I'm having some installation issues. Everything was going smoothly until the pip install idtrackerai where I got the following errors:


ERROR: Cannot install idtrackerai==3.0.22, idtrackerai==3.0.23, idtrackerai==3.0.24, idtrackerai==3.0.25, idtrackerai==4.0.12, idtrackerai==4.0.5, idtrackerai==4.0.6, idtrackerai==4.0.7, idtrackerai==4.0.8 and idtrackerai==4.0.9 because these package versions have conflicting dependencies.

The conflict is caused by:
    idtrackerai 4.0.12 depends on opencv-python==3.4.5.20
    idtrackerai 4.0.9 depends on opencv-python==3.4.5.20
    idtrackerai 4.0.8 depends on opencv-python==3.4.5.20
    idtrackerai 4.0.7 depends on opencv-python==3.4.5.20
    idtrackerai 4.0.6 depends on opencv-python==3.4.5.20
    idtrackerai 4.0.5 depends on opencv-python==3.4.5.20
    idtrackerai 3.0.25 depends on opencv-python==3.4.5.20
    idtrackerai 3.0.24 depends on opencv-python==3.4.5.20
    idtrackerai 3.0.23 depends on opencv-python==3.4.5.20
    idtrackerai 3.0.22 depends on opencv-python==3.4.5.20

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

Apologies if this is too trivial, I'm not very experienced and cannot find any solution online. I would appreciate any help!

idtrackerai

unread,
May 31, 2023, 9:52:34 AM5/31/23
to wiktoria...@gmail.com, idtracker.ai users group
Hi,

You are trying to install idtrackerai in an environment with Python < 3.10. This makes newer idtrackerai versions (v5) not to appear as installation options because they require Python => 3.10.

Solution. Remove and create again the Conda environment making sure you add the "python=3.10" argument in the "conda create" command. Once your environment has Python 3.10, pip will consider idtrackerai 5.1.4 (the current version) as a compatible option and you will have no errors.

Jordi

El dc., 31 de maig 2023, 14:27, Wiktoria Rajewicz <wiktoria...@gmail.com> va escriure:
--
You received this message because you are subscribed to the Google Groups "idtracker.ai users group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to idtrackerai_us...@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/idtrackerai_users/2e2a5a35-c8bb-4e93-add8-ea91a3f17de7n%40googlegroups.com.

Wiktoria Rajewicz

unread,
Jun 1, 2023, 5:39:29 AM6/1/23
to idtracker.ai users group
Hi Jordi,

Good point, after fiddling around I decided to remove anaconda, miniconda and everything else and install everything again. It worked! Then I got an error Error: QT6: "qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found." which was solved by running

sudo apt-get install '^libxcb.*-dev' libx11-xcb-dev libglu1-mesa-dev libxrender-dev libxi-dev libxkbcommon-dev libxkbcommon-x11-dev (In case someone also had that problem).



Everything runs now except I keep getting an error 'Blob' object has no attribute 'is_an_individual' and asking me to contact support it this problem persists. Has anyone had that problem? The blobs are detected nicely and never exceed the number of individuals. Thank you again so much for your help!


Wiktoria

David Zonana

unread,
Jun 1, 2023, 12:25:02 PM6/1/23
to idtracker.ai users group
Hi Wiktoria,

I too am having trouble with the python -m pip install idtracker command on Ubuntu. The install fails when it tries to collect the PyQt6 package with "error: metadata-generation-failed." It appears as though your errors were also with QT6. Did you also get this metadata error? 

Thanks, 
David

idtrackerai

unread,
Jun 6, 2023, 9:15:31 AM6/6/23
to idtracker.ai users group
Hello Wiktoria, David and users in general,

Regarding the 'Blob' object has no attribute 'is_an_individual' error when tracking some specific videos. It has been fixed and the next idtrackerai release will contain its patch. Thanks Wiktoria for notifying.

Regarding the Could not load the Qt platform plugin "xcb" error when running idtrackerai's GUIs. This is an error I have been facing lately. I think it's related to the fact that I work with the latest non-LTS (and a bit unsupported) Ubuntu version. Installing sudo apt install libxcb-cursor0 seems to work for me, and that's what I wrote in the documentation. I have no deeper understanding of the cause of this problem.

Regarding the error: metadata-generation-failed error when installing PyQt6. Some users have notified me this issue since one week ago. As I can't reproduce this error, it is being hard for me to solve it. I'm trying my best.

Jordi
Reply all
Reply to author
Forward
0 new messages