error in installing mzR on macOSX

78 views
Skip to first unread message

Nishikant Wase

unread,
May 27, 2014, 9:27:59 PM5/27/14
to id...@googlegroups.com
> sessionInfo()
R version 3.1.0 (2014-04-10)
Platform: x86_64-apple-darwin13.1.0 (64-bit)

I am having error in installing mzR.  I tried directly from bioconductor 

Bioconductor version 2.14 (BiocInstaller 1.14.2), ?biocLite for help
> biocLite("mzR")
Using Bioconductor version 2.14 (BiocInstaller 1.14.2), R version
  3.1.0.
Installing package(s) 'mzR'

   package ‘mzR’ is available as a source package but not as a binary

Warning message:
package ‘mzR’ is not available (for R version 3.1.0) 


Moreover when i tried to compile it from source, it didnt worked either:

1 error generated.
make: *** [rnetCDF.o] Error 1
ERROR: compilation failed for package ‘mzR’
* removing ‘/Library/Frameworks/R.framework/Versions/3.1/Resources/library/mzR’
* restoring previous ‘/Library/Frameworks/R.framework/Versions/3.1/Resources/library/mzR’

The downloaded source packages are in
‘/private/var/folders/7v/2lqj7wxj1wj5lsnk8tfxvv180000gn/T/RtmpS0kOm2/downloaded_packages’
Warning message:
In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
  installation of package ‘mzR’ had non-zero exit status

any idea how to get around this?

This mzmatch is not working both on mac osX with R 3.0.1 and on linux 64bit R 3.0 or R2.15 version.

Any help to get around this would greatly appreciated.

thanks

Nishi

Andris Jankevics

unread,
May 28, 2014, 7:09:31 AM5/28/14
to Nishikant Wase, Ideom
To compile mzR from source you will need to have a NetCDF libraries installed on you machine. For MAC pehaps this can help: http://www.unidata.ucar.edu/support/help/MailArchives/netcdf/msg11807.html.

For Ubuntu Linux: sudo apt-get install libnetcdf-dev

Andris 

--
You received this message because you are subscribed to the Google Groups "Ideom" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ideom+un...@googlegroups.com.
To post to this group, send email to id...@googlegroups.com.
Visit this group at http://groups.google.com/group/ideom.
For more options, visit https://groups.google.com/d/optout.

Reply all
Reply to author
Forward
0 new messages