mzR and Rcpp version not compatible

82 views
Skip to first unread message

Thomas Pouplin

unread,
Nov 22, 2016, 11:00:36 PM11/22/16
to Ideom
Hello IDEOM users,

I've been using IDEOM a while ago and really enjoyed it.
I recently had a new dataset (lipids) to process and wanted to have a go. But since the R update to version 3.3.2, it does not work at all.

This is the message I got from the R console after trying to use the mzmatch script (R - 32 bits):


Content type 'application/x-gzip' length 118159 bytes (115 KB)
downloaded 115 KB

* installing *source* package 'mzmatch.R' ...
** R
** preparing package for lazy loading
Warning in fun(libname, pkgname) :
  mzR has been built against a different Rcpp version (0.12.7)
than is installed on your system (0.12.8). This might lead to errors
when loading mzR. If you encounter such issues, please send a report,
including the output of sessionInfo() to the Bioc support forum at 
https://support.bioconductor.org/. For details see also
Error : .onLoad failed in loadNamespace() for 'rJava', details:
  call: fun(libname, pkgname)
  error: No CurrentVersion entry in Software/JavaSoft registry! Try re-installing Java and make sure R and Java have matching architectures.
ERROR: lazy loading failed for package 'mzmatch.R'
* removing 'C:/R/R-3.3.2/library/mzmatch.R'
Warning messages:
1: running command '"C:/R/R-3.3.2/bin/i386/R" CMD INSTALL -l "C:\R\R-3.3.2\library" "mzmatch.R.tar.gz"' had status 1 
2: In install.packages(pkgs = "mzmatch.R.tar.gz", repos = NULL, type = "source") :
  installation of package ‘mzmatch.R.tar.gz’ had non-zero exit status

I've tried to downgrade the Rcpp package to previous versions but none of them work ...

Any advice from here ?

Thanks

Thomas

Thomas Pouplin

unread,
Nov 24, 2016, 11:39:03 PM11/24/16
to Ideom
Downgrading R from 3.3.2 to 3.3.1 did the trick.

I still had plenty of issues but manual package installation using the tar.gz files worked ...

The rJava issue has been painful to fix and was somehow locking everything but using IDEOM in R 32 bits was OK (although I'm using windows 7 pro 64 bits and the newest Java 8.111 said to perform in 64 bits...).

I am now looking forward to see the results...

Cheers,

Thomas
Reply all
Reply to author
Forward
0 new messages