Looking for Source of ideservd 0.33

2 views
Skip to first unread message

pcollins

unread,
Jan 5, 2022, 7:17:52 AMJan 5
to IDE64
Still missing the Source of ideservd 0.33.

regards pcollins

Kajtár Zsolt

unread,
Jan 6, 2022, 6:13:10 AMJan 6
to id...@googlegroups.com
> Still missing the Source of ideservd 0.33.

0.33a is on testing at the moment and as it has the potential of breaking
Ethernet PCLink it's not public until I'm not sure that it works. Possibly
some later version will be released as I already made fixes to 0.33a.

The Ethernet PClink protocol was changed to avoid the need for setting up
static ARP entry for an IP address. This normally needs administrative
privileges and the idea was to use multicast to avoid that. Also due to a
silly mistake some routers didn't pass PClink traffic between their ports even
if they were assigned to the same network without the need of any routing.

These changes worked on Linux/BSDs fine and also on Wine. However that does
not mean it works on Windows.

So I've asked a friend to check this for me over the busy holiday period and
of course it didn't work on his setup. We tried to figure out why but even
then it was only working partly which is essentially still broken.

I used ETFE and a v3.4 card for testing as nothing else was available at the
time. Yesterday I've found my RR-net and it turned out that I made a typo
which broke the card configuration in IDEDOS so no wonder it didn't work.

This was corrected now in r1112. It seems to work here but of course no
feedback yet on such short notice if that was the only problem we had.

If anyone is interested in Ethernet PCLink testing for 0.33 please drop a mail
to the address in the changelog file.

ps.: after some fixes in 0.33 I've managed to compile and run ideservd on some
old MIPS32 based router with OpenWRT 21.02.1. As expected it can be used to
shares files from the internal or USB storage device. I've tried with Ethernet
but it might work with other PClink types as well.

--
-soci-
Reply all
Reply to author
Forward
0 new messages