Which command?

0 views
Skip to first unread message

toddlikesbeer

unread,
Mar 1, 2011, 3:13:52 PM3/1/11
to ic...@googlegroups.com
Assume the obligatory new to ruby\cucumber\iCuke.  I really want to get this figured out to use at my medium sized iPhone Development company, even know everyone is telling me it's not ready for prime time.  So far:
During trouble shooting I noticed a few differences:
  • The launch command for the Aslak example is "rake features", and reports "# lib/icuke/icuke_world".
  • The launch command for the Pragmatic example is "cucumber XYZ.features", and reports "# iCuke-0.6.3/lib/icuke/cucumber.rb:219".

As I was just typing this I went through the motions again, AND IT WORKED!  Though I'm not sure why.  The only thing I did recently was to install RVM.  So, now as excited as I am that it finally worked, I have the 3 following questions:

1. Why does one example use a Rake command while the other uses a Cucumber command?
2. Why does one example report icuke_world while the other reports cucumber.rb?
3. Should I have needed to install RVM to get it to work or is that simply a coincidence?

Any an all assistance is MUCH appreciated.  I really love the community supporting community aspect of this and plan to do the same once I get this all nailed down. I want to put together a white sheet for newbies, as so many of us seem to be, as a lot of the examples assume a certain level of knowledge.  








Jason Felice

unread,
Mar 1, 2011, 4:20:50 PM3/1/11
to ic...@googlegroups.com, toddlikesbeer
The rake command can make things easier.  If you start with a Rakefile, you can in all sorts of details and run a little bit more automated.  The 'rake' command effectively (though not really) runs 'cucumber' with some options.

icuke_world.rb is something that is in the most recent version from the git repository, while cucumber.rb is something that is in the last version that was packaged as a gem.  So it looks like you were running different versions of iCuke.  I've moved to the git repository version, as there are some problems with the gem version which have been resolved since.

You don't _need_ RVM.  My guess is that RVM's magic for finding modules set you up to use the right iCuke when you had two installed... but just a guess.
Reply all
Reply to author
Forward
0 new messages