Icon gets weird white stroke lines added when inserted into the font.

26 views
Skip to first unread message

kouko...@gmail.com

unread,
Sep 10, 2018, 1:57:59 AM9/10/18
to IcoMoon
I have this svg icon:
https://we.tl/t-SwgPHf3ow4
...and when I insert it into the font, I get this result:
https://ibb.co/kUSrn9

I have tried setting the `stroke` to `none`, but it doesn't seem to help.

Any ideas?

Keyamoon

unread,
Sep 10, 2018, 10:23:31 AM9/10/18
to IcoMoon
That's strange. In what browser and OS are you seeing this issue?

kouko...@gmail.com

unread,
Sep 11, 2018, 4:12:45 AM9/11/18
to IcoMoon
I am using the latest Opera and Win7. When I view the SVG in my browser alone, it seems fine. Only when I import it into the font it seems modified. That's why I think it is not my software that renders it wrong, but rather a side-effect of some transformation taking place during upload on the iconmoon site.

Here is the resulting font that I get:
https://we.tl/t-vgdNe0kNeC

Keyamoon

unread,
Sep 12, 2018, 4:17:45 AM9/12/18
to IcoMoon
I don't see any problem on macOS. Try the attached SVG. See if you will still have the same issue.
arrow-decision2.svg

kouko...@gmail.com

unread,
Sep 18, 2018, 5:56:24 AM9/18/18
to IcoMoon
Hm...
Yes, using the new SVG you attached solves the problem.
Thanks a lot! :)

Can you tell me what did you do to it, using Illustrator?
It might come handy in the future. :)

Keyamoon

unread,
Sep 18, 2018, 11:56:24 PM9/18/18
to IcoMoon
I used the Unite option in the Pathfinder window.

kouko...@gmail.com

unread,
Sep 19, 2018, 1:44:41 AM9/19/18
to IcoMoon
Thanks. :)
Reply all
Reply to author
Forward
0 new messages