Generated fonts don't contain the entire font (TTF)

25 views
Skip to first unread message

Allan White

unread,
Nov 17, 2014, 3:29:34 PM11/17/14
to ico...@googlegroups.com, Allan White
Greetings. I love icomoon! I've been using it to curate a nice icon set for my web app. 

Since last week though, downloading the generated fonts yields a font that 1.) won't load in OSX's Font Book, and 2.) when previewed, is only showing a couple icons. The .ttf size is also smaller than expected.

The html web demo seems to work locally (though I'm guessing they're not loading the .ttf). I need to use the font on my local machine for design work. Am I doing something wrong? Is there an issue with the font generator that I need to be aware of? 

Attached is my .json file. Thanks for reading, and for sharing the awesome icomoon app!

Best, 

Allan White
selection.json.zip

Keyamoon

unread,
Nov 17, 2014, 4:03:53 PM11/17/14
to
Hi,

I just updated the documentation to answer yours other similar questions regarding locally installed fonts. Please refer to it here: https://icomoon.io/#docs/local-fonts

I hope this helps.

Kristy Marcinová

unread,
Dec 10, 2014, 8:56:49 AM12/10/14
to ico...@googlegroups.com, allan...@healthsparq.com
Hey, I have a similar problem.

The local file doesn't work at all. It seems the .ttf file is broken or something - after selecting the font in an app, it ignores it and goes back either to the default one or the previous selected font.
Reply all
Reply to author
Forward
0 new messages