2.7.1 Upgrade task - Column not found: 1054

84 views
Skip to first unread message

John Hewson

unread,
Jan 15, 2023, 10:32:04 AMJan 15
to AtoM Users
Hi,

I'm trying a test installation of AtoM 2.7.1, which all runs very smoothly until I try the upgrade task (from a 2.5 database), when I get a red warning:

[wrapped: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'digital_object.LANGUAGE' in 'field list']

A quick grep takes me to

lib/model/om/BaseDigitalObject.php

where there's a new language field.

If I remove lines

13:       LANGUAGE = 'digital_object.LANGUAGE',
33:       $criteria->addSelectColumn(QubitDigitalObject::LANGUAGE);

the upgrade task runs successfully.

But do I need that language field? Anyone else seeing this or am I missing something obvious?

Thanks,

John

John Hewson

unread,
Jan 16, 2023, 10:48:24 AMJan 16
to AtoM Users
Seems to something affecting upgrades from older versions: If I upgrade from 2.6.4-184 the upgrade task runs successfully and the digital_object table acquires the new language column. If I upgrade from 2.5.2-172, the script bails unless I edit the object model, as above, and then I get no new column. Any suggestions welcome. Thanks, John

Dan Gillean

unread,
Jan 16, 2023, 12:27:36 PMJan 16
to ica-ato...@googlegroups.com
Hi John, 

Most common reason for these types of upgrade errors is people accidentally skipping Step 4 of this section - dropping and then recreating the database: 
See also this post: 
Please let us know if this helps! It would be good to determine if this is just another instance of a missed step or an actual bug in 2.7.x that we need to fix. If you try the drop and recreate method and it has no different effect on the outcome, let me know and I will see if our team can reproduce the issue locally. 

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/8b8453a2-1834-448e-8be8-747d1575a8d3n%40googlegroups.com.

John Hewson

unread,
Jan 16, 2023, 3:15:17 PMJan 16
to AtoM Users
Thanks Dan, but I've been religiously dropping and creating all the while, and every sort of cache has been cleared, and I've started over with a full fresh installation, just in case. The upgrade repeatedly works reliably for 2.6.4-184, but not for three separate instances of 2.5.3-172 that I've tried. I hope you can reproduce this. Cheers, John

José Raddaoui

unread,
Jan 17, 2023, 10:27:46 AMJan 17
to AtoM Users
Hi John,

Thanks for reporting this issue, we have been able to reproduce it and filed:


As you noticed the issue only happens when upgrading from 2.5.x (or lower) to 2.7.x and the workaround you used seems okay to me as long as you add those lines back after running the upgrade task and before restarting the AtoM services.

Best regards,
Radda.

John Hewson

unread,
Jan 17, 2023, 1:31:32 PMJan 17
to AtoM Users
Thanks Radda, good to have that confirmed. Cheers, John

Rodolfo Oramas

unread,
Feb 9, 2023, 9:07:27 PMFeb 9
to AtoM Users
Thanks John for the workaround!

I had to restart the migration from zero and it worked great.
My first try had a SQLSTATE[42S22]: Column not found error about password.
Reply all
Reply to author
Forward
0 new messages