Setting Admin Email and Password

35 views
Skip to first unread message

dpye...@gmail.com

unread,
Apr 24, 2019, 11:31:43 AM4/24/19
to AtoM Users
Hi all,
I'm VERY new here, I work at the Norfolk Record Office Archive Centre in the UK, and am trying to test AtoM in a virtual machine running on a laptop.
I've installed Ubuntu 16, which is running well, and I've successfully installed AtoM as per the Linux install instructions on your site.
Now here's the thing, during the actual installation of AtoM, I received the 504 timeout error, just before I was asked to set an email and login password.
To fix that issue, I did the PHP purge, and a few of the other suggestions on this forum, eventually something clicked and it now opens from localhost/ which is great. BUT I don't have a log in!

Is there a default login email and password which I need to use or do I need to reinstall? Or is there a config file somewhere in Ubuntu which I can edit to set the email address and password?

Thanks a lot for any assistance you're able to offer.

David

Dan Gillean

unread,
Apr 24, 2019, 12:07:43 PM4/24/19
to ICA-AtoM Users
Hi David, 

I'm not sure exactly what happened during installation, but you can create an admin account to log in from the command-line, with the following task: 
  • php symfony tools:add-superuser 
The task will prompt you to enter an email address, password, and username. You can also pass these all at once using the command options - for example, to create a new user with the username of atomuser, email atom...@example.com, and password of AtoM4Life, you could enter the command like so: 

As a side note, we have a Vagrant box for local testing and development, that makes it so you don't need to do the installation manually. See: 
 
Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/479399cc-cdfd-4daf-88ae-159c3f78f868%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

David Pye

unread,
Apr 24, 2019, 12:18:52 PM4/24/19
to ica-ato...@googlegroups.com
Hey Dan,
Thanks a lot for that, I think I must have found that information just as you had posted this as I've just got in and up and running.
Nice, thanks for the info on the vagrant box, it's not so much for me to test AtoM as we're currently already in the process of moving our archive over to AtoM here. But it was actually to test how hard it would be to set up a Linux Server, running AtoM, to use in a community archive setting. Turns out it's pretty easy! (When the Virtual Machine doesn't die in the middle of installation!)

Just a note, when I ran the add-superuser command with the username, email and password within the command itself, I received a syntax error. In the end the first command you suggested was what worked.

Thanks again for your reply, extremely helpful indeed!
D

You received this message because you are subscribed to a topic in the Google Groups "AtoM Users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/ica-atom-users/ySUpYi9zEDs/unsubscribe.
To unsubscribe from this group and all its topics, send an email to ica-atom-user...@googlegroups.com.

To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.

Dan Gillean

unread,
Apr 24, 2019, 1:26:45 PM4/24/19
to ICA-AtoM Users
Hi David, 

I'm glad you got it working! Strange about the command syntax - I've just tested it with both methods in our upcoming 2.5 release, and it appears to work. Hopefully if there was a bug, we've resolved it in the upcoming release!

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

David Pye

unread,
Apr 24, 2019, 1:56:01 PM4/24/19
to ica-ato...@googlegroups.com
So, I left the office, and about half way home realised why the syntax was wrong. I left the <brackets> around the username. My bad, super sorry to have wasted your time on that one.

But once again, thanks so much for the pointers on adding superusers, very useful indeed.

Dave

Dan Gillean

unread,
Apr 24, 2019, 3:29:08 PM4/24/19
to ICA-AtoM Users
Hi David, 

Ah yes! When I was looking at the docs, I realized that was likely confusing - which is why I included a full example in my forum response! 

I will try to get those brackets removed in the documentation example to avoid such confusion in the future. 

Regards, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory

Reply all
Reply to author
Forward
0 new messages