Re: [atom-users] Virtual Machine installation

43 views
Skip to first unread message

Dan Gillean

unread,
Nov 5, 2018, 10:54:04 AM11/5/18
to ica-ato...@googlegroups.com
Hi Amanda, 

Troubleshooting virtual appliances like this can be tricky, because the issue is rarely with AtoM, but rather some kind of interaction between your host computer, VirtualBox, and Vagrant. 

In this case, I did a bit of online searching, and the most common solution I found posted for the issue you reported was to try manually restarting the VirtualBox service from the command-line. Try these commands: 
  • sudo /Library/StartupItems/VirtualBox/VirtualBox restart
  • sudo "/Library/Application Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh" restart
The first command may not work, depending on how VirtualBox was installed in your system, but according to most posts, the second command worked consistently. Another user also recommended the following: 

Go to System Preferences > Security & Privacy Then hit the "Allow" button to let Oracle (VirtualBox) load.


Other suggestions included: 
  • Making sure you've installed or upgraded to the latest version of Virtualbox and Vagrant
  • Uninstalling and re-installing Virtualbox
  • Doing a hard reboot of your computer
Let us know how it goes!

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory


On Sat, Nov 3, 2018 at 1:06 PM 'Amanda Tomé' via AtoM Users <ica-ato...@googlegroups.com> wrote:
Hello all,

I recently purchased a new computer and wanted to install AtoM in a Virtual Machine for some testing. I have done this before with no problems. However, when I try to do the install now I get an error message:

There was an error while executing `VBoxManage`, a CLI used by Vagrant

for controlling VirtualBox. The command and stderr is shown below.


Command: ["hostonlyif", "create"]


Stderr: 0%...

Progress state: NS_ERROR_FAILURE

VBoxManage: error: Failed to create the host-only adapter

VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory

VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface

VBoxManage: error: Context: "RTEXITCODE handleCreate(HandlerArg *)" at line 94 of file VBoxManageHostonly.cpp


I am using a Mac and both Virtual Machine and Vagrant are up to date. 


It is likely that I am doing something wrong at my end but am not sure what.


Any help is greatly appreciated.


Thank you and have a great day.


Amanda

--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/ce4345e9-2776-4cf9-be9c-213825df9db7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages