Vagrant up stuck at 0% (First Time Installation AtoM 2.6.1)

48 views
Skip to first unread message

Mizan Samsudin

unread,
Dec 22, 2020, 10:29:03 PM12/22/20
to AtoM Users
Hello everyone, I am a new user trying to learn how to use AtoM to archive my stuffs. I followed the steps listed on the website to install AtoM 2.6.1. I already Installed Vagrant and Virtual Box on my windows 10 pc. However, when I tried to run 'vagrant up' after following all the steps listed, the progress did not change and stuck at 0%. I tried to follow the steps and doing the same thing for several times but still the progress do not move at all. 

============================================================
This is the log:

Microsoft Windows [Version 10.0.18362.1139]
(c) 2019 Microsoft Corporation. All rights reserved.

C:\Users\Ethnic Creative>cd DEsktop

C:\Users\Ethnic Creative\Desktop>cd atom-vagrant

C:\Users\Ethnic Creative\Desktop\atom-vagrant>vagrant init artefactual/atom
`Vagrantfile` already exists in this directory. Remove it before
running `vagrant init`.

C:\Users\Ethnic Creative\Desktop\atom-vagrant>vagrant up
A Vagrant environment or target machine is required to run this
command. Run `vagrant init` to create a new Vagrant environment. Or,
get an ID of a target machine from `vagrant global-status` to run
this command on. A final option is to change to a directory with a
Vagrantfile and to try again.

C:\Users\Ethnic Creative\Desktop\atom-vagrant>vagrant init artefactual/atom
A `Vagrantfile` has been placed in this directory. You are now
ready to `vagrant up` your first virtual environment! Please read
the comments in the Vagrantfile as well as documentation on
`vagrantup.com` for more information on using Vagrant.

C:\Users\Ethnic Creative\Desktop\atom-vagrant>vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'artefactual/atom' could not be found. Attempting to find and install...
    default: Box Provider: virtualbox
    default: Box Version: >= 0
==> default: Loading metadata for box 'artefactual/atom'
==> default: Adding box 'artefactual/atom' (v2.7.0.1) for provider: virtualbox
==> default: Box download is resuming from prior download progress
Download redirected to host: storage.accesstomemory.org
Progress: 0% (Rate: 13092/s, Estimated time remaining: 59:48:30)     

=========================================================

The progress remains at 0% no matter how many times I tried to repeat the process. What should I do? Thanks in advance.     

Mizan Samsudin

unread,
Dec 28, 2020, 8:30:11 PM12/28/20
to AtoM Users
I tried downloading the vagrant box file without using the 'vagrant up' cmd on the terminal. The BOX file for version 2.7.0.1 was downloaded successfully. However, can I just simply paste the 2.7.0.1.box file into the atom-vagrant directory and then run the 'vagrant up' command again ?

or 

Are there other steps that I missed ?

Dan Gillean

unread,
Jan 4, 2021, 10:34:24 AM1/4/21
to ICA-AtoM Users
Hi Mizan, 

It looks like you might have already had a vagrantfile in the directory on your first attempt, which could be causing issues? 

You might try using vagrant box prune to remove older versions, or vagrant box remove to clean up the directory. See: 
I have also manually removed boxes in the past by navigating to C:\Users\your-user-name\.vagrant.d\boxes\artefactual-VAGRANTSLASH-atom and deleting any undesired boxes from here. Be sure to swap in your windows username where it says "your-user-name" in the above example path. 

Perhaps this might help. Let us know how it goes! 

Cheers

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/85dce262-bd38-4e4b-8be3-f348cf02587dn%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages