Problem with thumbnails

128 views
Skip to first unread message

Alessandro Librelato

unread,
Apr 23, 2013, 3:33:27 PM4/23/13
to ica-ato...@googlegroups.com
Hello,

I made a upgrade from old version ica-atom 1.2.1 to 1.3.0, i not so sure if my problem started happen after that..

Well, when i try make a upload for thumbnails, the image .jpg or .png, the picture stay with 0 bytes and ofc i cant see nothing.
I made this config in my debian server "chown -R apache-user /var/www/icaatom-1.3.0", but still not work.
If i make a normal upload, like a normal picture, i can open this picture without problem.

Is this what i make for upload the thumbnails
I click in "Edit digital Object" -> Thumbnail representation -> select a file .jpg
The page make upload but with 0 bytes.

In debug mode, the page not show me any error.

Sorry my very bad english

Can someone help me please?

Alessandro

JBushey, ICA-AtoM Product Manager

unread,
Apr 23, 2013, 6:26:59 PM4/23/13
to ica-ato...@googlegroups.com
Dear Alessandro,

I am sorry, but I am having trouble understanding the question.
What type of upload are you trying to do?
If you speak Spanish, we do have a developer that speaks Spanish, if that is easier for you to communicate.

Best,
Jessica Bushey

Alessandro Librelato

unread,
Apr 24, 2013, 8:14:57 AM4/24/13
to ica-ato...@googlegroups.com
Dear Jessica,

Sorry... i speak portuguese and abit english :(

Ill try explain better.

In the menu, i click first in "Archival descriptions" after this i select a archival -> i click in "Edit digital objects" -> after, i make a upload in "Thumbnail representation", the file is .JPG.
Well, after make this upload, the file stay with 0 bytes.

Attached have some screenshots.

I hope you can understand now :)


Best,
Alessandro
icaatom.rar

Jesús García Crespo

unread,
Apr 24, 2013, 11:03:53 AM4/24/13
to ica-ato...@googlegroups.com
Hi Alessandro,

I think that the following issue is related to your problem:

You can use the patch attached to the issue in order to fix it.

Let us know how it goes.

Regards,


Alessandro

--
You received this message because you are subscribed to the Google Groups "ICA-AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msg/ica-atom-users/-/KY7kbRCM_FcJ.

For more options, visit https://groups.google.com/groups/opt_out.
 
 



--
Jesús García Crespo,
Software Engineer, Artefactual Systems Inc.
http://www.artefactual.com | +1.604.527.2056
Message has been deleted
Message has been deleted

Alessandro Librelato

unread,
Apr 25, 2013, 8:36:58 AM4/25/13
to ica-ato...@googlegroups.com, je...@artefactual.com
Hey Jesús.

look

icaatom:/var/www/icaatom-1.3.0# patch -p0 < /tmp/issue2424.patch
patching file lib/model/QubitSetting.php
Hunk #1 succeeded at 30 (offset 1 line).
icaatom:/var/www/icaatom-1.3.0# ;/symfony cc

Before make that, i stoped apache2 and after finish i started.

Still not work, nothing change..
by the way, ins't only the "thumbnail" who not work, "Reference representation" not work yet, have same problem, after make upload, stay with 0 bytes.

What do you think i can do now?

Alessandro

Jesús García Crespo

unread,
Apr 25, 2013, 9:22:01 PM4/25/13
to ica-ato...@googlegroups.com
Maybe an issue with your permissions? Is your uploads directory writable by the user running the web server?


To view this discussion on the web visit https://groups.google.com/d/msg/ica-atom-users/-/J_PKNTwID0kJ.

For more options, visit https://groups.google.com/groups/opt_out.
 
 

Alessandro Librelato

unread,
Apr 26, 2013, 9:28:25 AM4/26/13
to ica-ato...@googlegroups.com, je...@artefactual.com
when i staled, i pay attention about permission, i made this
chown -R www-data /var/www/icaatom1.3.0
this is my all permissions. 
www-data is my apache user

drwxrwxrwx  3 www-data www-data 4.0K Apr 23 08:54   apps
drwxrwxrwx  3 www-data www-data 4.0K Apr 25 08:36   cache
drwxrwxrwx  3 www-data www-data 4.0K Apr 23 14:48   config
-rwxrwxrwx   1 www-data www-data 3.7K Jan  1  1970   COPYRIGHT
drwxrwxrwx  2 www-data www-data 4.0K Apr 23 08:54   css
drwxrwxrwx  6 www-data www-data 4.0K Apr 25 08:36   data
-rwxrwxrwx   1 www-data root     771K Apr 23 08:58       db_20130423045822.sql.bak
-rwxrwxrwx   1 www-data www-data 183K Jan  1  1970   ead.dtd
-rwxrwxrwx   1 www-data www-data 1.2K Jan  1  1970    favicon.ico
drwxrwxrwx  3 www-data www-data 4.0K Apr 23 08:54   images
-rwxrwxrwx   1 www-data www-data  228 Apr 23 14:41   index.php
drwxrwxrwx  2 www-data www-data 4.0K Apr 23 08:54   js
drwxrwxrwx 10 www-data www-data 4.0K Apr 23 08:54  lib
-rwxrwxrwx   1 www-data www-data  34K Jan  1  1970   LICENSE
drwxrwxrwx  2 www-data www-data 4.0K Apr 23 08:54  log
drwxrwxrwx 33 www-data www-data 4.0K Apr 23 08:54 plugins
-rwxrwxrwx  1 www-data www-data  589 Jan  1  1970    qubit_dev.php
drwxr-xr-x    3 www-data www-data 4.0K Apr 23 10:00   r
-rwxrwxrwx  1 www-data www-data  323 Jan  1  1970   README
lrwxrwxrwx  1 www-data www-data   49 Apr 23 08:55    sf -> /var/www/icaatom-1.3.0/vendor/symfony/data/web/sf
-rwxrwxrwx  1 www-data www-data  445 Jan  1  1970   symfony
drwxrwxrwx  6 www-data www-data 4.0K Apr 23 08:54  test
drwxr-xr-x     4 www-data www-data 4.0K Apr 23 15:32 uploads
drwxrwxrwx  8 www-data www-data 4.0K Apr 23 08:54  vendor

Jesús García Crespo

unread,
Apr 26, 2013, 10:57:44 AM4/26/13
to ica-ato...@googlegroups.com
I'm running out of ideas.

We have our next release almost ready. You may want to give it a try to see if that helps to fix your problem. This is the temporary link: https://github.com/artefactual/atom/archive/v1.3.1-rc1.tar.gz, it's a release candidate. You could use it in production but I would recommend to wait until the final release which should happen next week.

Let us know how it goes.
To view this discussion on the web visit https://groups.google.com/d/msg/ica-atom-users/-/c7z-bXqX5cwJ.

For more options, visit https://groups.google.com/groups/opt_out.
 
 
Message has been deleted

Dan Gillean

unread,
Apr 29, 2013, 6:40:25 PM4/29/13
to ica-ato...@googlegroups.com, je...@artefactual.com
Hi there Alessandro,

I posted a message earlier, but it has disappeared. Here it is again:

ICA-AtoM uses ImageMagick to generate its reference representations and thumbnails. It is possible that it is not installed on your server, or that something happened to it during your upgrade. Find more information here: https://www.qubit-toolkit.org/wiki/Minimum_requirements#Other_dependencies_.28not_required.29

For some basic instruction on installing ImageMagick, see: https://www.qubit-toolkit.org/wiki/Installing_ImageMagick

Let me know if that helps! Best of luck,

Dan Gillean
AtoM Product Manager / Systems Analyst
Artefactual Systems, Inc.
www.artefactual.com

Alessandro Librelato

unread,
Apr 30, 2013, 10:58:41 AM4/30/13
to ica-ato...@googlegroups.com, je...@artefactual.com
Hey!

I installed imagemagick and made this config.

Added to /var/www/icaatom-1.3.0/apps/qubit/config/qubitConfiguration.class.php

32  public function configure()
33  {
34     putenv("PATH=".'/opt/local/bin:/opt/local/sbin:'.$_ENV['PATH']);
35     $this->dispatcher->connect('response.filter_content', array($this, 'responseFilterContent'));
36   }

After this

Added to /Applications/MAMP/Library/bin/envvars:

DYLD_LIBRARY_PATH="/opt/local/lib:/Applications/MAMP/Library/lib:$DYLD_LIBRARY_PATH"

this folder, Applocations.... not exist, i created that and set permission to www-data (apache user)

Restart apache2

But still not work :(

Alessandro Librelato

unread,
Apr 30, 2013, 11:20:04 AM4/30/13
to ica-ato...@googlegroups.com, je...@artefactual.com
also i instaled Ghostscript and ffmpeg, but still not work, like i tell you before, the upload of thumbnails and representation stay with 0 bytes, is so much strange...

Alessandro Librelato

unread,
Apr 30, 2013, 11:23:45 AM4/30/13
to ica-ato...@googlegroups.com, je...@artefactual.com
Also i installed ghostscript and ffmped, but still not work
is stranged coz after make upload in thumbnails and representantion, the file stay with 0 bytes



Em terça-feira, 30 de abril de 2013 11h58min41s UTC-3, Alessandro Librelato escreveu:

Jesús García Crespo

unread,
Apr 30, 2013, 12:04:32 PM4/30/13
to ica-ato...@googlegroups.com
It's hard to tell what's wrong with your system without access. If you have some experience with PHP, I'd try to open /lib/model/QubitDigitalObject.class.php and take a look to the code and maybe add some logging entries to help you finding what's the problem. If you are running out of ideas my recommendation would be to install Linux in a virtual machine and do a fresh install.

Regards,


--
You received this message because you are subscribed to the Google Groups "ICA-AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msg/ica-atom-users/-/Yc8tKdXOLGAJ.

For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply all
Reply to author
Forward
0 new messages