EAD 2002 XML export doesn't work

39 views
Skip to first unread message

Giuseppe Romano

unread,
Nov 5, 2021, 4:31:57 AMNov 5
to AtoM Users
Hi,
i have this problem, when i try to export to EAD 2002 XML after few seconds, the 
response is "Proxy Error the proxy server received an invalid response from an 
upstream server..."

Atom version: 2.3
OS: Ubuntu 18.04
php: php7.0-fpm 
web server: NGINX

I try to modify NGINX file configuration but without success. 

I add this line:
...
..
proxy_connect_timeout 300;
proxy_send_timeout 300;
proxy_read_timeout 300;
send_timeout 300;
...
location ...(index... {
   ....
   ....
fastcgi_connect_timeout 300;
fastcgi_send_timeout 300;
fastcgi_read_timeout 300;
   ....
   ....
}
Any suggest?

Thanks
Have a nice day

Giuseppe

Dan Gillean

unread,
Nov 8, 2021, 11:02:24 AMNov 8
to ICA-AtoM Users
Hi Guiseppe, 

I have a couple initial recommendations for you.

First, AtoM uses the Base URL set in Admin > Settings > Site information when attempting to build your XML exports. Please make sure that this includes the correct base URL for your site - do not end with a slash at the end of your base URL (e.g. use https://www.example.com not https://www.example.com/ as the URL). It's possible the fix required is simply this! 

In terms of execution limits, you may also want to check and adjust the values in the PHP pool created during installation at /etc/php/7.0/fpm/pool.d/atom.conf. See: 
You may want to try increasing values like the max_execution_time, memory_limit, and post_max_size. You can also check the global values configured in your php.ini file. See: 
How large is the EAD XML file you are trying to generate - as in, how many descendant records are in the archival unit? Currently in AtoM, EAD is generated on-demand via the browser, so large files may time out before completing. Are you able to export a smaller test description with a few children as EAD XML? Is this happening to all descriptions, or just some?

You could also try a command-line EAD export, using the --single-slug option. See: 
Finally, note that upgrading could help resolve this issue. Though I don't think this is the cause of the issue, we never tested AtoM 2. with Ubuntu 18.04, but this is the recommended O/S version for AtoM 2.6. Also, not only have there been a number of performance enhancements in later releases, but there are also additional features and tasks that may help, such as the ability to generate XML files asyncrhonously in advance via the job scheduler, so that they don't need to be generated on the fly via the browser (which may time out before large files can be generated). See: 
Let us know what you find and how it goes!

Cheers, 

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him


--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/d8f4e8f9-a03e-4c58-a0a9-34645e615658n%40googlegroups.com.

Giuseppe Romano

unread,
Nov 10, 2021, 2:37:49 PMNov 10
to AtoM Users
Hi Dan,
thanks for your suggests. 
The configuration of Atom is as expected from the various stages of the installation. 
I tried to change the settings in the PHP configuration files but without success.
The cause could be the size of the archive...

I also have another problem.
On the authority records page, on the left side, there are not all the relationships.

I have tried this sequence of operations:
1. php symfony cc 
2. Restarting PHP-FPM
3. php symfony propel:build-nested-set
4. php symfony search:populate

but unfortunately it didn't work , this is the most important problem to be solved for me

Thanks Dan

Giuseppe Romano

unread,
Nov 11, 2021, 2:31:43 AMNov 11
to AtoM Users
Hi Dan,
This morning I saw that the relationship list has a maximum of 30 entries on the
authority records page. Is there any setting to change?
Thanks Dan
have a nice day

Giuseppe Romano

unread,
Nov 12, 2021, 6:10:55 AMNov 12
to AtoM Users
hi Dan,
I found it on the administration page, the setting is ..visible element!
Now I have only one problem .. export to ead.
Thanks

Dan Gillean

unread,
Nov 12, 2021, 9:55:01 AMNov 12
to ICA-AtoM Users
Hi Giuseppe, 

I'm glad you've found some solutions! 

In terms of the EAD export: it's really hard to say what the issue might be without knowing a lot more information about the records you are trying to export and your installation environment. However, I would refer you back to some of the initial suggestions in my first response: 
  • Have you tried using the command-line EAD export with the --single-slug option to see if it works as expected?
  • Have you tried using the option to pre-generate and cache the EAD XML, so it is not trying to generate in the web browser when requested?
My hope is that these options will help you achieve what you need, and may also help us clarify that this issue has to do with file size, execution limits, and the web browser timeout, as opposed to a problem in the export code or something in the description metadata that is breaking the export when converting to EAD. 

Let us know how it goes!

Cheers,

Dan Gillean, MAS, MLIS
AtoM Program Manager
Artefactual Systems, Inc.
604-527-2056
@accesstomemory
he / him

Reply all
Reply to author
Forward
0 new messages