Skip to first unread message

Damian Bauder

unread,
Dec 9, 2016, 2:54:20 PM12/9/16
to AtoM Users
I'm passing along an issue from one of our archivists regarding the typeahead search feature. It doesn't seem to behave as expected. I'm not sure if this is a failure of the indexer, or an issue with the length of the strings and how the typeahead feature works with multiple search terms, or a combination. In the example below, the archivist is searching for a specific collection entitled "Miscellaneous Photograph Collection". I would expect the typeahead to display that result fairly early as the user enters the terms, probably by the time they've reached "miscellaneous pho".
 
  1. Begin searching. The typeahead works...
     
     
  2. ... for the first 10 characters, until we type the 11th character and then it disappears.
     
     
     
     
     
  3. Continuing, we expect it to turn up the desired description, at least somewhere in the top 3, but it doesn't (is it completely ignoring "miscellaneous" at this point?). 
  4. Continuing with "photograph", then "coll", still no consideration for "miscellaneous".
     
     
     
     
     
  5.  Yet, searching for "miscellane photograph", with only the first 10 letters in "miscellaneous", brings up a match in the typeahead (3rd from the top).

Is this a known issue, or a configuration change that can be made to fix it?

Thanks,

Damian

Damian Bauder

unread,
Dec 9, 2016, 2:55:58 PM12/9/16
to AtoM Users
This is in 2.3, by the way

David Juhasz

unread,
Dec 9, 2016, 7:57:13 PM12/9/16
to ica-ato...@googlegroups.com
Hi Damian,

Huh, I don't remember this bug being reported in the past, but I've reproduced it on https://archivescanada.accesstomemory.ca/ and https://albertaonrecord.ca/ which are both running AtoM 2.3 as well.  I've created a bug ticket for the problem: https://projects.artefactual.com/issues/10670

I had a brief look at the code, but I couldn't see anything obvious that would prevent the search from returning results for words longer than 10 characters, but that is clearly what is happening.


Best regards,
David
--

David Juhasz
Director, AtoM Technical Services Artefactual Systems Inc. www.artefactual.com

On Fri, Dec 9, 2016 at 11:55 AM, Damian Bauder <drba...@ucalgary.ca> wrote:
This is in 2.3, by the way

--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-users+unsubscribe@googlegroups.com.
To post to this group, send email to ica-atom-users@googlegroups.com.
Visit this group at https://groups.google.com/group/ica-atom-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/ica-atom-users/ad7f9920-7789-43e6-8b19-3c6953d3ebe0%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Damian Bauder

unread,
Jan 2, 2017, 12:16:44 PM1/2/17
to AtoM Users
Hi David,

I'm just checking in after the holidays. I hope yours went well, and thanks for the update here!

Damian


On Friday, December 9, 2016 at 5:57:13 PM UTC-7, David at Artefactual wrote:
Hi Damian,

Huh, I don't remember this bug being reported in the past, but I've reproduced it on https://archivescanada.accesstomemory.ca/ and https://albertaonrecord.ca/ which are both running AtoM 2.3 as well.  I've created a bug ticket for the problem: https://projects.artefactual.com/issues/10670

I had a brief look at the code, but I couldn't see anything obvious that would prevent the search from returning results for words longer than 10 characters, but that is clearly what is happening.


Best regards,
David
--

David Juhasz
Director, AtoM Technical Services Artefactual Systems Inc. www.artefactual.com

On Fri, Dec 9, 2016 at 11:55 AM, Damian Bauder <drba...@ucalgary.ca> wrote:
This is in 2.3, by the way

--
You received this message because you are subscribed to the Google Groups "AtoM Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ica-atom-user...@googlegroups.com.
To post to this group, send email to ica-ato...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages